2

I've been playing through Assassin's Creed 2 and am on Sequence 13 where you must kill the 9 lieutenants. I've killed 8 of them and suddenly the final objective marker for the 9th has disappeared. It was there before I killed the 8th. I've climbed every tower, so there isn't any area I haven't explored. Is there something I'm doing wrong?

Alternatively, is there a way to recover one of the past save files so I don't have to start from scratch?

Any help you can provide is greatly appreciated!

  • Do you have any active objective markers? – svavil Jan 8 '16 at 5:27
  • @svavil, none whatsoever. And it still says 8/9 lieutenants killed in the upper left corner, so the mission is not complete. – Poisson Fish Jan 8 '16 at 15:23
  • 1
    The game allows to turn the display of certain group of markers on and off. Can you check if quest markers are set to display? – svavil Jan 8 '16 at 15:49
  • @svavil, thanks for the reply. I should have pointed out I'm on PC, which doesn't have the toggle option I don't think. If so, how do you do that? Google is failing me on this one. – Poisson Fish Jan 9 '16 at 0:56
  • I used to play it on PC several years ago, and I think I was able to toggle marker display in the map menu. Will reinstall the game and try to reproduce it in a couple of days. – svavil Jan 9 '16 at 1:14
3

Solution

I ended up leaving the Florence city and coming back through a quick travel booth, which appears to have restored the objective marker.

Other things I tried without success:

I decided to try downloading another save file from this website and can't see objectives on that either. I also reinstalled the game (keeping my save file in a separate folder during the install) with no luck. Oh well, the above solution worked.

  • Wow, seems like a strange issue. Glad you have it resolved, though. – svavil Jan 9 '16 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.