So I spent what seems like forever downloading Dota 2 to my Ubuntu PC, only to find out that it requires OpenGL 3.1, which my Intel integrated graphics doesn't support.

Can I make Dota 2 use a previous version of OpenGL or "enable" support for 3.1?

  • 1
    Can you try to run with DirectX instead? I'm no UNIX guru so that may be a stupid question. Use the launch option "-dx11" or "-dx9" under Properties of Dota 2 in steam library
    – Judge2020
    Jan 14, 2016 at 0:35
  • You might be able to get some more technical help here: github.com/ValveSoftware/Dota-2
    – Decency
    Jan 15, 2016 at 9:14
  • 1
    Pls more information about your hardware
    – Opaldes
    Apr 26, 2016 at 12:04

2 Answers 2


No, you can't run the game with an older version of OpenGL API. Nor can you "upgrade" your software to add OpenGL 3.1 (or newer) support, unless your hardware itself supports it, and newer drivers are available which enable it.

You need to find the detailed specs of your GPU (or CPU if using internal graphics on Intel/AMD) to see if it supports the version of OpenGL, and then if so, make sure you are using the correct drivers for your GPU. Depending on the GPU you're using, and version of Ubuntu you're on, you may need to switch to different drivers.


Not knowing your entire system, it's difficult to help. Dota 2 on Ubuntu has some issues, and I'm not sure your GPU can handle it well - can you perhaps elaborate your system?

I would first and foremost go to launch options and force directX. Either run -dx9 (for directx 9) or -dx11(for directx11) to remove the OpenGL option.

I am, however, afraid you're on a laptop that does not have a good enough GPU(and likely other components) to run the game properly.

Try running steam --reset as suggested here

  • I'm using a desktop. You're probably right, might get some lag, but I wanna try and get this working. One sec, I will try your guys' suggestions.
    – jadenPete
    Jan 15, 2016 at 1:43
  • I tried using both options, but I get the same error: imgur.com/q0cXktI
    – jadenPete
    Jan 15, 2016 at 1:47
  • Don't think that you can use DirectX on linux, without Wine (A program to run windows software on linux). I ran it from the command line and found that multiple directx libraries are missing, which are nowhere to be found on my system or on Google.
    – jadenPete
    Jan 15, 2016 at 2:23
  • Look at this thread, same error. Perhaps that can help. Run steam --reset in terminal and get back to us if it worked.
    – cbll
    Jan 15, 2016 at 9:00
  • 3
    Linux doesn't support directX.
    – ave
    Jan 15, 2016 at 9:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .