2

I have a computer with 8GB of ram. With this I can play with a distance of 16 chunks (200+ fps), and now I want to try to play with far distance. However, I need to increase the RAM amount in the profile properties tab. When I set the ram to 2G, the game won't run.

Java settings for the profile: javaw -Xmx2048 -Xms1024

I have installed 64-bit java in my computer.

Why I can't set more RAM?

If it is useful: The profile is vannilla minecraft (no mods). It doesn't start.

  • What happens when it doesn't run? Do you get an error message or crash dump? What does it say? – fredley Jan 28 '16 at 16:46
  • @fredley Nothing shows up, just the game won't run. – spund3 Jan 28 '16 at 16:46
  • How does it "not run"? Does it cease running mid-load, or does it not even start? – user1337 Jan 28 '16 at 16:47
  • @user1337 It doesn't start. – spund3 Jan 28 '16 at 16:47
  • Are we talking about a clean MC, or modded? – user1337 Jan 28 '16 at 16:48
3

Looks like the launcher is using 32-bit Java instead. If you have the correct Java version installed, it should look like this:

Minecraft Launcher - Profile Editor Screenshot

where Executable option points to the 64-bit Java executable file (either java.exe or javaw.exe).

  • Maybe that's the problem. I'll look it. – spund3 Jan 28 '16 at 17:32
-2

If you want to set the RAM to 2 Gigabytes, try typing "-Xmx2G" instead. If you ever seem to need more RAM for any reason, you can add more to the number; for example, typing "-Xmx3G" for 3 Gigabytes, "-Xmx4G" for 4 gigabytes, and so on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.