I'm trying to download Terraria in this case, and I have tested the download speed of this computer's adapter already; 1.5mb/s. Despite this, downloading things in Steam will only reach up to 150kb/s. I have switched from 4 servers, I live in Florida so I tried Houston, Atlanta, New York, and Miami. All 4 gave me the same speed or worse. Please help.

I have another computer with Steam on it that runs Windows 10, but can download up to 3mb/s. This is an issue on here.

EDIT: I do recommend checking all the solutions people have given, it doesn't seem my solution was universal. Hope you can figure it out here.

  • Another thing to note is that whenever I try to download things, after trying to use things like Firefox, the whole computer is now as slow as Steam was.
    – user132026
    Jan 31, 2016 at 23:40

7 Answers 7


Might be a silly suggestion but have you tried going into Settings and checking whether there's a bandwidth download limit set on your account?

It's found under the Downloads tab. Once clicked, there should be a little dropdown menu.

  • Unfortunately, this doesn't seem to be my issue. Thanks for the help though.
    – user132026
    Jan 31, 2016 at 23:38

I just figured out my issue. For whatever reason, it was really slow because I didn't install something called dnsmasq. I'm running Xubuntu, so it would work after a restart because a version of it was already installed that was dnsmasq-base. I don't completely understand what this even did, but it made my download speeds go from 150kb/s to my normal speeds.

Hope this helps anyone else having my issue :)


I had the same problem and the dnsmasq solution did not work for me, neither did changing download server or set a download limit. I hope this will help others in the future:

The problem for me was that my steam folder was on a mounted ntfs partition with sync enabled (check /etc/fstab). That throttles write-speed significantly. Change sync to async and I have normal writing speeds which means Steam can download at full speed, too.

  • 1
    Yeah and how does that work...
    – Andrew
    Mar 21, 2019 at 22:18
  • Before changing this setting, make sure you know what the consequence is!
    – jvriesem
    Feb 3, 2020 at 12:58

On Linux Mint Cinnamon 19 (and possibly most of Ubuntu based OS) :

In a terminal :

sudo nano /etc/sysctl.conf

In nano editing add this lines at the bottom of the file :

net.ipv6.conf.all.disable_ipv6 = 1

net.ipv6.conf.default.disable_ipv6 = 1

net.ipv6.conf.lo.disable_ipv6 = 1

Save and close

In the terminal :

sudo sysctl -p

Sources : https://forums.linuxmint.com/viewtopic.php?t=210093

  • 2
    This is the only solution that worked for me.
    – alvinc
    Apr 7, 2019 at 18:16
  • 1
    It seems that one needs to run the command (sudo sysctl -p) in every session (after reboot).
    – alfC
    Dec 10, 2019 at 5:06

I found another solution to installing dnsmasq. You use unbound instead.

# apt-get install unbound # do this first or you'll be sad
# cd /etc/NetworkManager
# service NetworkManager stop
# vi NetworkManager.conf # or whatever editor you want; I don't care
[change "dns=dnsmasq" to "dns=unbound"]
# rm /etc/resolv.conf # don't forget this
# service NetworkManager start

This would tell DNS queries to go through your local unbound server (at a.k.a. localhost), retries over TCP should work as expected, and Steam should be able to download just fine. You can test it with:

# nslookup cdn.comcast.cs.steampowered.com

This, together with marts' answer helped me solve this issue. For a better explaination of why the above works, see this post.


I just fixed my issue with this. What I did was

sudo systemctl disable systemd-resolved
sudo systemctl stop systemd-resolved

and then

sudo systemctl enable systemd-resolved
sudo systemctl start systemd-resolved

I don't know how this works but it did.

  • Wow yeah that did it, TYVM!
    – Andrew
    Mar 21, 2019 at 22:20
  • So pulling information from here and here: ebugg-i.com/technology/linux/… freedesktop.org/software/systemd/man/… "systemctl may be used to introspect and control the state of the systemd(1) system and service manager." "systemd-resolved is a system service that provides network name resolution to local applications." So basically, like the other solutions, it seems to be a DNS-related problem, something to do with resolving network connectivity.
    – Andrew
    Mar 21, 2019 at 22:23
  • Excellent! This also worked for my Steam within Wine! (I paused the Steam download within Wine, ran these commands in Linux Mint 19.1 which was running Wine, and then resumed the Steam download within Wine.)
    – Andrew
    Apr 3, 2019 at 4:11

The slow download speeds could also be, if you are using a dual-boot system, the way that the ntfs partition is mounted could also result in the download taking forever. Assuming you are downloading the games to your ntfs partition. As it has to download and simultaneously transfer the data to the partition(if you are using the mount argument sync).

If you are using a dual-boot system and are experiencing slow download speeds, also consider this as a possibility. Changing your 'auto-mount' settings in /etc/fstab could make a difference. Here is the answer I am basing this on: Very slow write rate from ext4 to NTFS. And the fact that it was the case for me.

As a side note, here is how to setup the partitions to auto mount.

You must log in to answer this question.