-3

So I want to start a small Minecraft server to raise money toward a bigger one, so I download a Spigot server (and I have owned some servers in the past so I knew how to set it up). When I finish setting up port forwarding and all that crap, then when I start it up it says this:

**** FAILED TO BIND PORT!

So I went online to find how to fix it and I was met with a number of different methods. I tried changing the port, changing the IP, using the cmd, using task manager, closing Java, and then started it back up. I was met with the same message. I tried to fix again, but it still gave me the error.

What I see

  • No that didn't help. The ip feild is filled and the other tasks running on the same port are closed. Thanks tho – Can Colsto Feb 3 '16 at 1:29
  • 2
    Showing your IP is not wise. You should be careful to censor it in the future. – Schism Feb 3 '16 at 8:11
  • Yes thank you. I caught that right after i posted it. And i could not figure out how to change it. thank you for doing so – Can Colsto Feb 3 '16 at 21:38
1

If you are running your server in your private (home) network, be sure that the server IP is the local IP of your computer/server in your network not the one who is accessible from public.

You can check if your current IP is a local one:

10.0.0.0 to 10.255.255.255
172.16.0.0 to 172.31.255.255
192.168.0.0 to 192.168.255.255

If your current IP in server.properties is included in above ranges, there you go.

As Aidan Mueller mentionend, left it blank will automatically take your local IP.

|improve this answer|||||
  • Yes! Thank you that worked! One more question. Where do i find the ip to share it w/ friends when i leave it blank? Is it the ipv4 address? – Can Colsto Feb 3 '16 at 21:48
  • If i type in the ipv4 nothing comes up except: java.net.ConnectExeption: connection timed out: No further information – Can Colsto Feb 3 '16 at 22:50
0

IP
I'm not sure if you ever need to fill the IP field. I have always left it blank, so try that first.

Port
A BindException is usually caused by a port being in use. It looks like another program may be using that port. This question has information on checking for open ports. That should help you find an open port. One answer says that this command will show you ports that are in use:

netstat -a -b
|improve this answer|||||
  • It said The requested operation requires elevation. What does that mean? – Can Colsto Feb 3 '16 at 5:04
  • @CanColsto You need to move the computer a bit higher for it to work. Put some books under it :P. OK, seriously. It means that the command needs to be run as administrator. Start the command prompt as administrator first. – Lysol Feb 3 '16 at 7:42
  • thaink you. And for the record. I do have books under my pc tower XD – Can Colsto Feb 3 '16 at 13:21
  • @CanColsto If my answer fixed the problem, don't forget to accept. – Lysol Feb 3 '16 at 20:24
  • Ok i went through a few times but i dont see anything that has 25565 on it. What now? – Can Colsto Feb 3 '16 at 21:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.