2

enter image description here

As you can tell, when I'm in the Avenger main screen as well as watching cutscenes, my fps drops significantly to around 10-30 fps, as well as my gpu reaching temperatures around 73 degrees C.

Basically, almost every part of the game has a significant visual lag even though I have a mid-tier gaming rig. This was tested on running low -> high settings, and the issues are still prevalent on low and high.

The issues:

  • Low framerate in Avenger HQ
  • Extremely low framerate when in Dropship
  • Low framerate in combat after concealment is lifted
  • In-game cinematics also have low framerate.

Anyone else getting this, and have a fix for this? Is this just a part of poor optimisation?

  • 1
    Sounds like the lack of proper optimization, usual in games just after their release. – Aventinus Feb 5 '16 at 8:59
  • I was having mid 20-30 fps in the Avenger screen on my 970, but the game defaulted to 8xMSAA. Dropping down to 2x, or FXAA pushed my frame rates back up to 50-60. – Kexlox Feb 5 '16 at 13:07
  • Looking at the steam reviews, bad performance is a very common complaint about the game. I guess we will have to wait for version 1.1 – Philipp Feb 5 '16 at 15:42
0

This was fixed in the first performance patch that Firaxis pushed through.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.