6

A few days ago, I picked up the Mass Effect trilogy on origin for like $10, and just yesterday I finished ME1.

I've tried to download ME2 several times now, and ME3 once as well, but both downloads failed at nearly 100%.

Specifically, when I download ME2, Origin says that it will be a 9.71GB download and a 11.57GB installation.

Each time I've tried downloading ME2, the download gets to 9.70GB, then the download speed drops to 0B/s, then Origin crashes with a "fatal error". Sometimes, Origin will give me a popup telling me there's been a "download error" before crashing. The same issue occurs with ME3, but I don't have the exact numbers, as I only tried it once.

I'm not certain whether this is an issue with my network, or if this is an issue on EA's side. I'm on my college's VPN, and I've been able to download large files without issue before. (In fact, I downloaded ME1 on this network when I purchased it).

I've tried running Origin as an Administrator, but the issue persisted.

Anyone know how to fix this issue?

  • 2
    It's failing on the unpacking apparently... Are you sure you have enough space? – Zerjack Feb 10 '16 at 15:49
  • 1
    Sounds like you need around 20 GB space.... maybe further complicated by the matter of downloading to one drive and installing to another? – user101016 Feb 10 '16 at 15:54
  • 1
    Also, if you're getting error codes it might be worth contacting their support team to take some of the guess work out of it. – Broots Waymb Feb 10 '16 at 16:03
  • @Zerjack I'm not getting error codes, and the drive has 512GB free atm – Charles German Feb 10 '16 at 18:28
  • Ok... Hmm any unusual things in your environment? Such as custom install paths, different admin rights structure or something like that? The way you say it I can only say Origin is busted. but I doubt the simpler solution is the correct one. – Zerjack Feb 10 '16 at 19:37
0

Turns out, it's an issue between my college's VPN and the way Origin downloads games.

I'm not an expert on networking, but I was able to use an off-campus network to download ME2 (admittedly, it took every bit of 5 hours...), and it worked just fine.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.