1

The scenario is as follows:
I run XCOM or XCOM 2 (the problem occurs for both). I do a task change to Windows and start another game (i.e. leave XCOM running in background), say Heroes of the storm (HotS). Whenever I have an extended waiting period in the other game, I'd switch back to XCOM and continue there.

This worked perfectly for some games (e.g. Battle Worlds: Kronos) but when running XCOM this has some severe disadvantages. I'm playing on my main screen (right side) and have another secondary screen set up on the left side - just showing windows desktop.

The problem:
Mouse doesn't stay in the HotS window. So whenever I hit left side of my main screen and accidently click, I'll switch to Windows. The mouse isn't bound to the game's screen.


As said: this problem occurs specifically for XCOM / XCOM2 and is not universal (although I can't say for sure it only happens for XCOM). Does anyone have a solution for this behavior? I want to keep running XCOM in background while playing HotS and still keep focus only in HotS.

  • I don't think I'm going to have a solution, but I also don't really understand the problem you're describing. You click outside of the game and it switches to what you clicked on? That seems correct. What did you want to happen instead? – DCShannon Feb 16 '16 at 18:07
  • The mouse should remain inside of HotS window and not just leave game window. Mouse should be bound to the game (which is normal behavior). I'll try to clarify my question in that regards. – StampedeXV Feb 16 '16 at 18:10
  • 2
    It isn't something that the background gaming is doing; it's something that the foreground game is not doing - capturing the mouse in exclusive mode. Not all games capture the mouse, and there's rarely anything you can do about it. – T.J.L. Feb 16 '16 at 18:18
  • If I end XCOM it works perfectly. So this problem only occurs in combination of XCOM running in Background and other game (e.g. HotS in foreground). – StampedeXV Feb 16 '16 at 18:58
  • I don't have a way to test it, but in my XCOM2 under options>video settings there is an option to lock the mouse to the window. Not quite what you're asking but it may have the desired effect of preventing the mouse from being detected by XCOM2 while in the other game. – JackArbiter Feb 16 '16 at 19:01
2

Rather than addressing the issue with XCOM directly, I suggest an indirect solution using window management software.

I have been using DisplayFusion to manage my windows and mouse cursor for many years, and although I haven't used it myself, there is a feature that lets you lock your cursor to the current monitor or active window by pressing a hotkey. See the screenshot below:

DisplayFusion functions tab

DisplayFusion has a basic free mode, but also has a 30 day trial for Pro, so you can test both of these functions and see if it works before buying. Hope that helps!

  • I've given up hope - this could really work. Thanks. – StampedeXV Aug 30 '16 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.