3

I thought I'd give GTA: San Andreas a go, given that I haven't played it yet, and having finished GTA V, I got a copy of GTA:SA and tried to run it on my computer.

Everything seems to work fine, except for the two DDR-like missions, and in fact all the DDR-like minigames (dancing in nightclubs, etc).

The arrows slowly creep to the center (the circle) from the right, but instead of going all the way smoothly, the game seems to skip ahead at least once per second, bringing up several "missed" messages on screen. Since the arrows do not pass by the circle smoothly, the two plot-critical dance missions are not complete-able.

I have tried many different varitions on display settings, trying pretty much all available resolutuibs, with 'widescreen' on and off, 'frame limiter' on and off, and all the other settings on and off.

Nothing seems to help, though. Also, I'm kinda poking in the dark with this, because I have no idea where to even look for a solution.

Aside from this, I didn't notice any other problems with synchronization, or something.

I believe the way the arrows should be synchronized, is evident in this video:

(one of the few videos, where people don't showcase how to use a glitch to skip the mission).

This is not at all what the arrows do in my case, where the whole set of arrows on screen gets replaces by a set of new arrows, and I get several "missed" messages at once on the screen (sometimes filling the whole screen with "missed" messages).


EDIT

This error was reproducible with both the installation I made from a DVD, and by getting it from Steam.

A partial improvement can be obtained by forcing the game to be started in Windowed mode. To do this, one needs to get hold of a file called d3d9.dll, I got mine from a rather dubious source (some mediafire link I've found in the description of a Youtube video). That file has something to do with older versions of DirectX, but I'm no expert on that. The file needs to be placed next to the gta_sa.exe in the directory where GTA:SA is installed.

Anyway, the game - and especially the DDR-like minigames - become playable once resolution is set to 800x600 or less in "FULLSCREEN", i.e. 4:3 aspect ratio.

It would be nice, if someone might shed some light on what this d3d9.dll file does, and a reliable - non virus infested - source for it.

  • 1
    Are you running the steam version? It was updated with bug-fixes, unlike the DVD release. – Ave Feb 17 '16 at 17:21
  • nope, I have a DVD version. – polemon Feb 17 '16 at 17:30
  • It has been a long time since I played this, but remember tweaking something in the realms of DirectX to get the game running - that was on Windows 7 32-bit. – user101016 Feb 17 '16 at 17:39
  • 1
    I just played the Steam version far enough, so I can see if the bug persists: yes it does :( – polemon Feb 17 '16 at 20:57
  • 1
    Possible duplicate of Low Rider Challenge – user598527 May 1 '17 at 16:02
2

I have never encountered the 'skipping' bug you describe, but in terms of getting 'misses' on beats, there may be another solution:

The game's timing for the rhythm sections, (especially the Lowrider challenge but also when Dancing), is off by a fair amount. Even on the old PS2 version running on a CRT (with little to no image preprocessing), the off-beat display of the buttons in the sweet spot is noticeable.

From my years of playing, the beat seems to be about 0.4 of a second off from the music in the Lowrider challenge, and closer to 0.2 off in the Dancing sections. You need to almost ignore the beat of the music, follow the incoming buttons, and press slightly after when you should.

Take this terrible MS Paint example I drew up in about 30 seconds: Example image of when to press buttons

Normally you would push to the beat of the music, which (ideally) would be represented by the middle of the blue circle. However, you need to hold off just slightly enough to press the button as it leaves the circle.

Personally, for years I actually muted the game during the Lowrider challenge as I found it that distracting, it took me a while to be able to pass with the music on.

As always, practice makes perfect, so save beforehand and just repeat the challenge over and over. Pattern memorisation also comes into play, as the buttons are in the same order every time. So keep at it and you'll get it eventually!

  • Yeah, that's not the issue at all for my problem. The game skips ahead up to five arrows ahead, which simply vanish and the next set of arrows appears instantly, this happens throughout the whole mini-game. Other than that, I'm quite used to rhythm games like that. I've been playing StepMania with a keyboard for many years. I'm afraid your answer is completely non-sequitur to my questions, though :/ – polemon Feb 18 '16 at 22:21
  • @polemon man, that sounds terrible, from the description in your question I thought it was only jumping a little bit :-(. I'll do some digging. Can you confirm you're running the game with your dedicated graphics card and not a low power one like 'Intel HD Graphics?' – Robotnik Feb 18 '16 at 22:48
  • Fwiw I played this on a crappy laptop with just the non gaming integrated graphics, without this issue. I know that doesn't help Polemon but it might help you (or anyone ) push through to the solution. :) – Mac Cooper Feb 18 '16 at 23:32
  • I think I might've found a partial solution, or be at least on to something: The skips are smaller, when I dropped a d3d9.dll into the game directory, which forces the game to be in windowed mode. I got this file from a rather dubious source from mediafire, It's still not perfect, but it seems the skips are smaller, the lower resolution I choose. What is the native resolution of the PS2 game, that used to be released originally? – polemon Feb 18 '16 at 23:56
  • @polemon - funnily enough I looked this up for an unrelated issue the other day. The PS2 outputs at 480i 30fps for NTSC, 576i 25fps in PAL regions. So about 720x480 resolution – Robotnik Feb 19 '16 at 0:01
0

I had the exact same problem on my laptop with the arrows jumping I had during the same dancing and lowrider games. I fixed mine by changing the compatibility mode to Windows XP Service Pack 3

0

There is a mod called SilentPatch that aims to fix a bunch of game bugs that exist since the initial release. One of the fixes is the dancing minigame timings:

Dancing minigame timings have been improved, now they do not lose accuracy over time depending on PC's uptime

-3

If you're running the game on a 64-bit system but playing the 32-bit version that could be to blame. If that is the case look for a patch - if you look in the disk itself sometimes they come with a 64bit patch.

Otherwise try Right-clicking on the .exe file (not the shortcut or autorun), go to properties and select run it compatibility mode for 32bit.

Also check your monitor setup. If your using a setup with progressive scan the game is likely loading certain frames ahead of time causing this glitch. Disabling progressive scan (ie setting graphics card settings to 1080i instead of 1080p may solve the issue.

Good luck.

  • It is a 5GHz quad core running on a GeForce 8200. The system is a native Windows XP, with 8GB of RAM (of which WinXP can only adress 3GB, to my knowledge). – polemon Feb 18 '16 at 5:09
  • You did not completely address all the issues I have cited above.I tried to be of help giving you many possible causes and solutions that may be applicable trying to be helpful.I don't deserve bad rep for tying. The use of a high performance graphics card possibly connected to a 1080p HDMI display would cause progressive scan effects to preload events which are time crucial and check the results before real-time display caught up. Resulting in the skipping frames as you described.try going to your graphics card settings and setting it manually to 1080i instead of 1080p. – Firobug Feb 18 '16 at 5:39
  • As a side note windows can likely only see the 3gb ram because you are using 32bit version of xp good for compatibility for most programs. I'd recommend you look into a boot level ramdisk and load xp onto it as this will allow you to have much quicker function of everything installed on it presuming you only use standby instead of full shutdown. – Firobug Feb 18 '16 at 5:54
  • 4
    You're not allowed to vandalize your answer because you got downvotes for it. You can delete it, but changing it so it no longer answers the question is seen as vandalization. To that end, I have rolled back your answer. – Frank Feb 18 '16 at 13:22
  • 320x480i I believe is the native formatting of old CRT TV systems – Firobug Feb 20 '16 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.