3

I've been trying to run Civilization:Beyond Earth, but either since I've upgraded to Windows 10 or the Rising Tide expansion came out (or both), I can't.

Most of the times, I get the launcher asking to select between regular or AMD Mantle. No matter which I choose, the launcher will come back.

After a couple of retries, I get an Error 53 (Steam servers are too busy).

I've found a couple of solutions that worked for other people, but they didn't for me:

  • Disable/remove anti-virus
  • Disable Windows Defender realtime scanning
  • Flush the Steam local cache with steam://flushconfig

I'm still getting the same problem, and the further I dig into the Steam support, I just keep seeing the same three things (and something about clientregistry.blob which apparently isn't a thing anymore).

So - what else is blocking me?

  • Did you log out of Steam and close its process down once you'd disabled the above & then restart Steam to try again? – Sean Feb 26 '16 at 14:51
  • Yes, I did as per instructions – HorusKol Feb 26 '16 at 21:58
1

I just tested Civilization BE on my Windows 10 laptop (upgraded from Windows 7) and saw it wouldn't launch. I verified the local game files and that worked for me; I'm able to launch and play without issues. But, there may other problems with your installation, specifically a firewall issue.

First, verify your local game files even if you've done it before, then reinstall DirectX and The Visual C++ Redistributable package. If that doesn't work, check the firewall.

In the Steam Library, Right Click on Sid Meier's Civilization Beyond: Earth
and select Properties
Under Properties, choose the Local Files tab and click Verify Integrity of Game Files

Wait for it to finish and try launching. If it doesn't work, reinstall DirectX and both the 32 and 64 bit versions of VCRedist. They're found under _CommonRedist in C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization Beyond Earth

Reopen the Civ BE Local Files tab
Choose Browse Local Files
This will open File Explorer and you'll be in C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization Beyond Earth
Now, double click on _CommonRedist
You'll see the DirectX and vcredist folders
First go to DirectX\Jun2010 and find and run DXSETUP.exe (you can find it by sorting your directory listing by file type)
Next, go into vcredist\2012 and run both vcredist_x64.exe and vcredist_x86.exe

Try running Civ BE again. If this doesn't work explore the firewall possibility. Without fiddling with the firewall, try disabling the Steam Cloud for the game.

In the Steam Library, Right Click on Sid Meier's Civilization Beyond: Earth and select Properties
Choose the Updates tab and, near the bottom of he windows, uncheck Enable Steam Cloud Synchronization

Try running. If it works, this tells you your issue is with a firewall rule. For CivBE to work, you should have two programs with full passthrough in the Windows 10 firewall, CivilizationBE_Mantle.exe and CivilizationBE_DX11.exe.

Click on your Start Button (The one with the Windows logo) or click the Windows key on your keyboard.
In the bottom left, look for the gear icon. Click that and it will take you to Settings
In the Find a setting dialog box, type Firewall
Choose Allow an app or feature through Windows Firewall
First, check for CivBE in the list, scroll down and look for two entries for the game.
All three checkmarks should be on for the two entries, Name, Private and Public.
If they're not there, you can add them by Clicking Change Settings at the top right of the Firewall window.
Then choose Allow another app at the bottom right.
Click Browse, next to Path and instead of drilling down to the right executable, copy/paste the following to add the entry for DX11:
C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization Beyond Earth\CivilizationBE_DX11.exe
and copy/paste this to add Mantle:
C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization Beyond Earth\CivilizationBE_Mantle.exe
Now, click OK on the main Firewall screen

Try launching Civ BE again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.