0

I tried to login on cosmicpvp but it says this server is out of date as do all my other servers. Shouldn't they automatically update. Please help.

  • Do you manage the server? – DJ Pirtu Feb 29 '16 at 18:13
  • It's up to the server owner to update the server, which could take them a long time if they have a lot of plugins to update. You may need to wait, or downgrade your client back to 1.8. – SirBenet Feb 29 '16 at 20:47
1

If you're using spigot and you've downloaded BuildTools.jar, then you'll need to run it inside a folder. This folder will contain the spigot.jar file.

  1. First, you need to download the minecraft server from Minecraft's official website. Skip this for spigot.
  2. Then, replace your old minecraft_server.jar with this new one. With spigot, use the spigot.jar instead
  3. Restart your server, and you're good to go!

EDIT: This will only work if you have access to edit the server's file. Most servers will not support 1.9 because it's not available for Spigot, as said above.

EDIT2: Spigot 1.9 is out! Download spigot here.

To answer your question about automatically updating, this is not a thing. People will need to follow the step above to update their server for Spigot or Vanilla. Also, this will be relatively fast, because the only thing that'll break plugins for 1.9 is sounds. A plugin that doesn't use sounds almost definitely works seamlessly on both 1.8 and 1.9

protected by Community Mar 2 '16 at 21:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.