4

When flying a spaceship if I press left shift briefly and let go immediately it beeps1 and switches the view mode2 in addition increasing the throttle. If I long press it it just increases the throttle as expected.

Why does it take me into IVA view in addition to adjusting the throttle and how do I make it stop?

I thought it might have to do with Karabiner interfering with KSP but I disabled it and the issue still occurs.

I'm running OS X 10.11.3.

Here are the plugins I have installed in case they're relevant somehow:

  • KerbalAlarmClock
  • Docking Port Alignment Indicator
  • KerbalEngineer
  • EditorExtensions

1As in a "you can't do that right now" beep.

2i.e. if I was looking at my ship then it switches to IVA.

  • Did you check your keyboard settings to see if one is double-mapped to IVA and acceleration? Prob not due to the difference in how long you press, but it's worth checking. – Tim S. Mar 1 '16 at 14:48
  • The only values using LeftShift in settings.cfg are: THROTTLE_UP { primary = LeftShift secondary = None group = 0 modeMask = 1 modeMaskSec = -1 } TRANSLATE_FWD { primary = H secondary = LeftShift group = 0 modeMask = -1 modeMaskSec = 6 } EVA_Pack_up { primary = LeftShift secondary = None group = 268435456 modeMask = -1 modeMaskSec = -1 } EVA_Run { primary = LeftShift secondary = None group = 268435456 modeMask = -1 modeMaskSec = -1 } Editor_fineTweak { primary = LeftShift secondary = None group = 0 modeMask = -1 modeMaskSec = -1 } – Lawrence Johnston Mar 2 '16 at 1:50
  • In particular these are the settings for toggling the view: CAMERA_MODE { primary = C secondary = None group = 0 modeMask = -1 modeMaskSec = -1 } – Lawrence Johnston Mar 2 '16 at 1:53
  • Oh, "beep". Are you sure it is game issue, not system one? I do not recall KSP having beeps anywhere, it sounds more like "Sticky Keys" or other disability helper. (it seems to work in OS-X in similar manner to Windows) – PTwr Mar 2 '16 at 7:58
3

I eventually tracked this down to the "Instant Send" functionality in LaunchBar which apparently uses shift as it's default hotkey. I suspect that it uses command-C to copy to the clipboard as part of its implementation which was causing the issue. I disabled this and everything is back to normal.

| improve this answer | |
  • Glad you got it figured out. Seems like a very annoying situation. – Tim S. Mar 2 '16 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.