2

When I insert the disc it says,

"D:\

The directory name is invalid"

I bought it here:

http://www.amazon.com/Baldurs-Gate-Box-Set-Compilation-Pc/dp/B002TOKQH2/ref=cm_cr_arp_d_product_top?ie=UTF8

I'm using Windows 10.

I tested with a different Windows 10 Computer, and the disc wasn't empty. But when I use my PC, the disc is read as empty.

I haven't fiddled with any settings regarding discs.

The problem isn't that I can't install Baldur's Gate; It's that my PC reads the disc as empty for some reason.

Why won't it run?


I uninstalled the CD rom device from device manager.

Then I rescanned for new hardware.

  • 3
    Probably because the 64-bit versions of Windows 10 no longer support most disc based copy protection methods. – user86571 Mar 4 '16 at 20:35
  • ...you're aware that Baldur's Gate and its sequel both have remakes, right? – Powerlord Mar 4 '16 at 20:58
  • Ooh there's an answer floating around on this site dealing with the copy protection issue that @RossRidge mentions, I'll see if I can find it – Robotnik Mar 4 '16 at 20:59
  • 5
    See if this helps: How to run old games installer on Windows 10? – Robotnik Mar 4 '16 at 21:03
  • @Powerlord Enhanced Edition costs about five times as much as the version OP bought and adds very little besides compatibility. I don't blame them for buying a second hand copy. – Studoku- Reinstate Monica Mar 4 '16 at 21:12
1

Most likely, your optical drive's DMA mode is in "PIO fallback mode" this is a severe compatability fallback that breaks discs that have purposely-built bad sectors in them (part of a copy protection mechanism).

I had this exact symptom once with Elder Scrolls Oblivion

The way to check this is to go into the device manager and identify the ATI/IDE/ATAPI controller that the optical drive is attached to (not the optical drive itself), and look for the transfer mode (advanced settings tab, check "Current Mode" column). If you cannot figure out which controller, sort the list "View > Devices by connection"

Windows keeps track of read errors on a counter and when certain thresholds are met, it steps back the transfer speed. The problem (I won't call it a bug because they haven't fixed it since at least XP) is that the counter is never reset. This makes sense for HDD, but not so much for optical media.

To fix it, remove the ATA/IDE/ATAPI controller (not the optical drive), reboot and let windows redetect it.

google "DMA PIO fallback mode"

|improve this answer|||||
  • for the future; best not to use technical jargon. Your not talking to the IT crowd, here, your talking to the general gaming population. – user106385 Mar 5 '16 at 14:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.