5

I'm playing Half-Life 2, Episode 1 on a mediocre laptop. Half Life 2 ran perfectly after tinkering with the video settings. I understand that Episode 1 is more demanding on the graphics.

The problem: after a few minutes of playing, without any issues, the game slows down and movements become jittery.

In earlier Half Life 2 games it would either run, or it wouldn't - making tinkering easier.

As of now, it seems that something during game playing goes awry and slows the game suddenly down. It doesn't happen gradually; somehow, at a given moment, it just jitters and abruptly slows down to an unacceptable level. It happens indoors, outdoors, enemies coming in or not, i.e., randomly in terms of game location. It seems to happen often after 5 minutes of game play or so. But sometimes it keeps on running smoothly longer.

I did tinker around somewhat with the texture detail and water reflections because I'm aware they are over the recommended settings. I also shortly tried disabling HDR and enabling bloom (whatever that may do), but troubleshooting is difficult due to the delay of the problem onset and sometimes randomness of slowing.

Any ideas what to do? Especially my knowledge on anti-aliasing and filtering is very poor and the game doesn't recommend settings for these options. I copied the settings from half-life 2 to Episode 1. Somehow the Radeon software suggested settings for HL2 that worked like a dream, but I can't get the Radeon software to work anymore. So I copied the settings from HL2 to Episode 1, in lieu of something more constructive.


laptop specs:

  • AMD quad-core 1.8 GHz
  • 8 GB RAM
  • Radeon R7 M260 (2 GB)
  • OS: Windows 10
  • Advanced Systems care to shut down background processes
  • When starting game, 2% processor power and ~20% RAM used up

In-game video options:

  • running game under Steam client
  • resolution: 1920 x 1080* (native full screen)
  • model detail: high*
  • texture detail: very high
  • shader detail: high*
  • water detail: reflect all
  • shadow detail: high*
  • color correction: enabled*
  • anti-aliasing: 4 x MSAA
  • filtering mode: anisotropic 6x
  • wait for vertical sync: off*
  • motion blur: disabled*
  • multicore: on*
  • High dynamic range: full*
  • bloom: off

*: recommended setting

  • 1
    Turn settings down from High / Very High to Medium. – MattR Mar 14 '16 at 14:48
  • 3
    I don't think the problem is with the graphics settings. A PC like that should be able to run even Portal 2 at high to very high settings in 60 FPS. And even if it didn't, the framerate should either be consistently good, or consistently bad. – Nolonar Mar 14 '16 at 14:51
  • 1
    @Nolonar - thanks for looking into this. If I need to add any other information other than graphics please let me know. Any pointer to the issue would be welcome, it's kind of a frustrating issue :( – AliceD Mar 14 '16 at 15:17
  • 2
    @Christiaan Downvotes happen. Don't sweat them unless they're outnumbering upvotes by more than 3:1, in quantities greater than, well, 3 and 1. If somebody feels something is 'fixable', they'll tell you, but plenty of downvotes are conveying a negative judgement that you can't solve. Sometimes that's because the question ought to be deleted, but sometimes it's because of the downvoters personal judgments that you can't address. – LessPop_MoreFizz Mar 14 '16 at 22:21
  • 2
    @Christiaan Off Topic is what close votes are for. You've gotten none of those. :) – LessPop_MoreFizz Mar 14 '16 at 22:51
6

I thought to provide the solution to my question here. Apologies for the noobieness, but for me it was quite a steep learning curve :

  • Diagnosis: I found out that when temperatures exceeded 90oC, the framerate drops. I used the freeware GPU temp to monitor my GPUs. The dedicated graphics card showed 0oC when not playing the game and I found out that the switchable graphics turns on the M7 dedicated GPU only when a full-screen application like a game is started.
  • The problem: issue of the slowing was a drop in frame rate due to overheating.
  • The solutions, in order of importance:

1) Cap the frame rate to 60 Hz (equal to the refresh rate of my monitor). In half life this can be done with fps_max [fps] in the console. I now use RivaTuner that comes tagged along with the freeware MSI afterburner to globally limit the framerate. Capping frames to the monitor's refresh rate doesn't impact gameplay. The gain in temperature is in the order of 10oC, likely due to the dynamic framerate of HL2 that peaks at rates exceeding 100 fps at times.

2) Disable HDR - I use a BenQ gaming monitor that also corrects for dark areas, and I see not much of a difference when turning high dynamic range off in HL2. Saves perhaps a few oC.

3) Lower water detail to simple reflections; I don't notice too much of a difference really and it saves quite a few oC when in watery environments.

4) Lower shadow detail to medium: may or may not help, but I do it anyway as it goes pretty much unnoticed, at least to me.

5) I replaced my mediocre laptop cooler with a Cooler Master Notepal XL. It features a fan airflow of 89.8 CFM, which is pretty good (as opposed to ~20 CFM of my previous cooler), However, the benefits of laptop coolers, other than raising the laptop from the bench, are disputed and so it's on the bottom of my list. I didn't check out whether it truly makes a difference. If any, it won't be much more than a degree or two.

My prime contributor to gameplay is texture details and that's left intact at very high.

In all, no loss in gameplay and a stable 75-85 oC with no drops in framerate.

3

Here's a guess: the game is either running on, or being switched to, your integrated graphics card.

As a debugging step can you try disabling the Intel HD video card you probably have as a GPU under Device Manager? Reboot and try again. You'll lose some features like brightness control in the process.

  • If I'm right the auto-switching is turned off for games, but I'll check it out, thanks! – AliceD Mar 14 '16 at 22:07
  • I checked it out and turning off the integrated GPU also shuts down the DVI connector output to my external monitor. I didn't pursuit this idea after that, but thanks any way. – AliceD Apr 8 '16 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.