5

I created a new Clash of Clans village with a new Google account on my secondary Android user. Once I started the game, I logged in with the Google account I had just created. When I tried to access the same village on my second Android device by creating a new user and logging in with the same Google account as on the other device, it just linked the new empty village to the account. It turns out the existing village from the other device wasn't linked.

So at this point I had linked a fresh village to the Google account. I tried what would happen if I tried logging in with the account on the original device again. It prompted me if I wanted to discard the current progress and continue with the level one town hall village. This was obviously something what I didn't want to do as I already had a level five village that I was supposed to link with the account.

As the wrong village was now linked with the account, I created yet another Google account and tried to login with that in Clash of Clans on the device and user that had the level five village. On the top of my screen I saw it greeting me for logging in with an account, but the Google sign in button in the settings stayd red saying disconnected. I thought it was a bug and logged into Clash of Clans with that account I thought I had just linked with the TH 5 village. Well, then I ended up having two level one villages linked to those two Google accounts and the level five one still disconnected.

Then I tried to use the link a device function in the settings. I clicked on it (after creating yet another new Google account and logging in with it) and selected that this was the old device. Clicking on the Android button it told to make sure I had logged in with a Google account on the current device and then to log in with the same account on the secondary device. From experience I knew that would end up with me having a third level one village linked with a Google account. I clicked on the I want to link to another device which then told me I was logged in with a wrong account.

Wrong account logged in

The current village is attached to a different Google account than the one you're signed into.

Please sign out of the current Google account from the settings screen, and sign in with the account attached to this village.

Then try linking again.

At this point I'm not sure what I'm supposed to do. I have no account linked with this village, as the original Google account I created to be used with this new village had a level two town hall attached to it. Clicking the red disconnected button on the settings screen to use that account it prompts me to discard my level five town hall and restore a level two from the Google account.

How do I safeguard my village with a Google account?

1

This has happened to me before and the same thing happened to me. What I did was log out of my google account, delete clash of clans then I logged back in then I redownloaded clash of clans and recovered my acc and it worked perfectly fine again.

  • If I delete the game, all progress is lost. If I link the Google account to the game, I will get a level 2 town hall instead of current level 5. – MikkoP Apr 6 '16 at 11:08
0

Try creating a new account to link, that works for me when this happens.

  • As I wrote in the question, I've tried this several times. – MikkoP Apr 9 '16 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.