My Minecraft crashes randomly whilst I play. For example when I shift-left-click rapidly my game crashes. Also when I start up Minecraft when I click anywhere on the screen, the whole Minecraft tab flickers.

I have put the crash details below, I'm not that experienced with this kind of stuff so I was hoping any of you could help me out at all.

[18:52:01 INFO]: Finished downloading C:\Users\octonuggets\AppData\Roaming\.minecraft\versions\1.9\1.9.jar for job 'Version & Libraries': Local file matches hash, using that
[18:52:01 INFO]: Job 'Version & Libraries' finished successfully (took 0:00:03.407)
[18:52:01 INFO]: Launching game
[18:52:01 INFO]: Unpacking natives to C:\Users\octonuggets\AppData\Roaming\.minecraft\versions\1.9\1.9-natives-1131111047737422
[18:52:01 INFO]: Launching in C:\Users\octonuggets\AppData\Roaming\.minecraft
[18:52:01 INFO]: Half command: C:\Program Files (x86)\Minecraft\runtime\jre-x64\1.8.0_25\bin\javaw.exe -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M -Djava.library.path=C:\Users\octonuggets\AppData\Roaming\.minecraft\versions\1.9\1.9-natives-1131111047737422 -cp C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\oshi-project\oshi-core\1.1\oshi-core-1.1.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\net\java\dev\jna\jna\3.4.0\jna-3.4.0.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\net\java\dev\jna\platform\3.4.0\platform-3.4.0.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\ibm\icu\icu4j-core-mojang\51.2\icu4j-core-mojang-51.2.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\net\sf\jopt-simple\jopt-simple\4.6\jopt-simple-4.6.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\paulscode\codecjorbis\20101023\codecjorbis-20101023.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\paulscode\codecwav\20101023\codecwav-20101023.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\paulscode\libraryjavasound\20101123\libraryjavasound-20101123.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\paulscode\librarylwjglopenal\20100824\librarylwjglopenal-20100824.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\paulscode\soundsystem\20120107\soundsystem-20120107.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\io\netty\netty-all\4.0.23.Final\netty-all-4.0.23.Final.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\google\guava\guava\17.0\guava-17.0.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\apache\commons\commons-lang3\3.3.2\commons-lang3-3.3.2.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\commons-io\commons-io\2.4\commons-io-2.4.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\commons-codec\commons-codec\1.9\commons-codec-1.9.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput\2.0.5\jinput-2.0.5.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\google\code\gson\gson\2.2.4\gson-2.2.4.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\mojang\authlib\1.5.22\authlib-1.5.22.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\com\mojang\realms\1.8.7\realms-1.8.7.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\apache\commons\commons-compress\1.8.1\commons-compress-1.8.1.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\apache\httpcomponents\httpclient\4.3.3\httpclient-4.3.3.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\commons-logging\commons-logging\1.1.3\commons-logging-1.1.3.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\apache\httpcomponents\httpcore\4.3.2\httpcore-4.3.2.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\apache\logging\log4j\log4j-api\2.0-beta9\log4j-api-2.0-beta9.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\apache\logging\log4j\log4j-core\2.0-beta9\log4j-core-2.0-beta9.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl\2.9.4-nightly-20150209\lwjgl-2.9.4-nightly-20150209.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl_util\2.9.4-nightly-20150209\lwjgl_util-2.9.4-nightly-20150209.jar;C:\Users\octonuggets\AppData\Roaming\.minecraft\versions\1.9\1.9.jar net.minecraft.client.main.Main
[18:52:01 INFO]: Looking for orphaned versions to clean up...
[18:52:02 INFO]: Looking for old natives & assets to clean up...
[18:54:04 ERROR]: Game ended with bad state (exit code -805306369)
[18:54:04 INFO]: Ignoring visibility rule and showing launcher due to a game crash
[18:54:04 INFO]: Deleting C:\Users\octonuggets\AppData\Roaming\.minecraft\versions\1.9\1.9-natives-1131111047737422
[18:54:04 WARN]: Couldn't delete C:\Users\octonuggets\AppData\Roaming\.minecraft\versions\1.9\1.9-natives-1131111047737422 - scheduling for deletion upon exit

3 Answers 3


A quick Google search shows that the error code -805306369 means that the Java Virtual Machine has run out of memory. To fix it, you need to allocate more ram to Minecraft.

Presuming you are using the official launcher, you can do this by selecting a profile, clicking 'Edit Profile' and increasing the -Xms (minimum ram) and -Xmx (maximum ram), by ticking the 'JVM Arguments' at the bottom.

Example arguments would be: -Xms1G -Xmx2G = Minimum of 1GB RAM, maximum of 2GB.

Hope this helped! Source: Here

  • Thank you, this worked for the most part. It stopped the screen flickering but I still get the occasional random crash, though it's a lot less common and will likely not be too much of a problem. Commented Mar 20, 2016 at 23:44
  • Glad to have helped :)
    – Sulphate
    Commented Mar 20, 2016 at 23:49
  • Actually after multiple tests, it seems to have not been fixed. The flickering continues but the crashes happen a lot less. Any other methods you may know of? Thanks. Commented Mar 20, 2016 at 23:53
  • Screen flickering is almost always caused by outdated or broken graphics drivers, especially if you are using an Intel graphics card. Try and update them, search for drivers for your card online.
    – Sulphate
    Commented Mar 20, 2016 at 23:56
  • Related
    – Joachim
    Commented Jul 10, 2019 at 7:26

-805306369 or 0xcfffffff is a Windows error code for STATUS_APPLICATION_HANG. It is not entirely clear to me when, exactly, this error is raised, but searching around seems to show occurrences have the following in common:

  • Unexpected and often hard to reproduce, and even harder to diagnose.
  • Happens in graphical applications; not unique to Minecraft or Java.
  • Typically thrown when in a kernel/system driver call.

Looking at these, I'm guessing that the error is raised by Windows as a sort of watchdog, making sure that a single application doesn't "hang" the system by spending a long time in a critical, possibly exclusive section. The cause may be a driver defect of some sort, which is where Sulphate's advice to update your graphics drivers will help you.

If the problem persists despite updating the graphics drivers, you might have a (transient) hardware problem. Although it's rare, hardware may end up in a state where a power cycle—shutdown + cold boot—is needed to 'unjam' it.

If you are using a laptop—or any other device with a battery, really—a power cycle is more involved. Batteries may leave a (very) small amount of charge on hardware even after you've powered off (*). This means that, when you boot, the hardware doesn't really boot from a clean slate, and it may awaken back into its 'bad' state.

Aside: I don't see it as likely that this is the case here. Then again, I've never seen this type of error before, and it may be hardware related, so this is a safe (if inconvenient) way to rule out bad hardware state as the source of the problem.

To do a power reset on a laptop:

  1. power down your laptop
  2. disconnect all peripherals (cables)
  3. wait 15 seconds
  4. turn laptop over and remove its battery pack
  5. wait at least 5 minutes for residual charge to dissipate
  6. re-insert the battery pack
  7. turn laptop right-side up again and boot it
  8. reattach your peripherals

(*) For instance, we once had a laptop issue where the network interface (NIC) disappeared from the Windows Device Manager. After the usual troubleshooting, we reset the power state as described. And the NIC happily popped back in existence again.

  • 1
    Could you edit this to include a statement about what the power reset is for? Commented Mar 21, 2016 at 16:24

I ran into the same problem, and I found that this was because of mods. I simply removed them, then added them back one by one until I found the one that was causing a problem.

Either find a replacement for this mod, or update it to hopefully have the issue fixed.

And if you don't use mods, simply... look at the other answers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .