8

Yesterday I was in the middle of a space shuttle orbit mission when something urgent came up that forced me to leave my computer. I exited the game, Kerbal Space Program.

Today I come back and find my only pilot with many missions under his belt is up in space in orbit (K.I.A according to the game)... I lost money on an expensive spaceship... I lost reputation... the list goes on. All because the game decided to autosave when I did not need it to or want it to.

In Kerbal Space Program, how do you disable autosave?

  • Note: in next update autosaves are supposed to be "rotating" exactly to prevent such issues. For now you can do it manually with quicksaves (ALT+F5 to save, ALT+F9 to load), having quicksave on launchpad is useful. Keybinding – PTwr Mar 22 '16 at 7:43
7

You can't disable autosave in KSP

Auto save can't be disabled in KSP. You can set it to only autosave after very long intervals however it still seems to autosave at the start of a launch.

To change the interval you'll need to open settings.cfg located in your KSP directory. There are two settings AUTOSAVE_INTERVAL and AUTOSAVE_SHORT_INTERVAL that you can increase as desired. A setting of -1 seemed to be ignored and autosaves continued as usual.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.