0

I installed Civ5 on Windows 7 and was able to run it fine on maximum settings on my laptop's Geforce 740M.

However, after running fine for two or three times, the game now hangs after the intro video, and will only actually start if I run it with the integrated Intel GPU, which can play the game reasonably albeit with lower quality.

I've tried disabling the intro video, reinstalled the nvidia GPU's drivers and the game itself, and also resetted all nvidia configurations to default, without success.

Edit: I'm also unable to run a DX10 performance benchmark using the nvidia GPU, but it runs with the Intel GPU. I've reinstalled two different older Nvidia drivers (353.30 and 359.06) and also reinstalled DirectX (KB2670838), the game still freezes on a black screen after the intro video, but runs fine on the Intel integrated GPU

Any hints of what can be causing this? Thanks!

  • 2
    Are you still able to play other games on high settings that would put your GPU under load? – Winter Mar 26 '16 at 19:30
  • 1
    We need more info on other games you've played; whether if you are experiencing issues only when gaming or not, and when the issues started to appear. Add any updates to your question. – Zerjack Mar 26 '16 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.