0

I'm trying to play games on a Windows 8.1 tablet with 1900x1200 resolution.

When I run some games which change resolution I see only their left-top quarter like game thinks that it's still 1900x1200 when it actually uses 800x600.

I tried to set a lower desktop resolution but it didn't affect what happens when I launch these games.

This happens in different games: "Starbound", "Star Wars: Knights of the Old Republic", "Baldurs Gate II".

The tablet has an Intel HD video.

How to fix it?

  • Some games will let you hit (left)Alt+Enter once or twice to resolve such issue. Might work for some, or all or none, give it a shot. – Иво Недев Mar 30 '16 at 14:53
  • @ИвоНедев no, it doesn't help. I can play some of them in maximized windowed mode but when I press alt+enter or set full screen in options it behaves like I wrote in the question. – Vlad Mar 30 '16 at 14:56
  • 1
    Perhaps this answer has the solution to your problem? – Nolonar Mar 30 '16 at 15:05
  • @Nolonar thanks, "Disable display scaling on high DPI settings" works! If you write an answer I will accept it. – Vlad Mar 30 '16 at 16:00
1

It seems you are experiencing a problem related to DPI scaling, as is usual with most mobile PCs running at resolutions close to or above Full HD (1920 x 1080) due to their relatively small size.

To fix this, you can disable DPI scaling. This answer explains how.


Keep in mind that disabling display scaling can lead to issues, where UI elements are rendered too small to be read. This is arguably a better outcome than not being able to see most of the game, however.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.