I am stuck on the Automaton quest line "A new threat" as I cannot install the radar beacon on Ada. There seems to be a bug if you build the robotic workbench directly after meeting Ada. I can only upgrade her legs.

As I am on PC, I tried looking for a workaround using console commands.

I found possible approach to reset the questline via:

GetStage  01000801
completeallobjectives 01000801
CompleteQuest 01000801

and to start the Headhunter questline via:

ShowQuestStages  01002833
SetStage 01002833 150

Yet it seeems that the quest ids do not work for me as the GetStage command only yields in Item '01000801' not found for parameter quest.

How to proceed the quest line using the console? I know that I can resort to a save, yet I rather not lose my current progress I made in between the Automaton quests.

  • Have you tried building another workbench?
    – DCShannon
    Mar 31, 2016 at 20:47
  • @DCShannon Yes, I scraped the first one and rebuild a second one. It did not change the behavior. It has a questmarker on it, yet nothing besides leg mods can be applied for Ada.
    – k0pernikus
    Mar 31, 2016 at 20:48

3 Answers 3


Robots.esm needs to be directly below Fallout4.esm in your load order for those bat files (or commands) to work. For instance, if you have another mod in between the command will only work if it is typed GetStage 02000801, if you have two mods in between it'll be 03000801, etc. I'm not suggesting that you retype the commands, the easiest way to resolve the issue is just to move Robots.esm directly below Fallout4.esm so that all its records begin with 01 and not 02 or 03, etc.

Also, a poster in the thread of the mod you linked to said:

not sure if anyone has mentioned this but by shooting ada until she needs a repair kit, then use one on her. Thats all it took to fix it for me.

If this is true, obviously it'll be the easiest, least invasive way to work around the issue. (confirmed working by OP)

If you have the 2nd inspirational perk and cannot damage Ada, you can still either try the first method or open the console and type:

player.removeperk 001d2462

Then damage and fix her, then type:

player.addperk 001d2462

According to k0pernikus, even if you have the third perk you only need to remove the 2nd perk for this to work.

  • Ada is my companion and I have the second Inspirational perk which makes companions immune against my attacks.
    – k0pernikus
    Mar 31, 2016 at 22:05
  • Edited my answer to address this issue. Mar 31, 2016 at 22:12
  • @k0pernikus Can you damage her if you dismiss her first?
    – DCShannon
    Mar 31, 2016 at 22:32
  • Removing the perk and then shooting Ada to defunction and repairing her gave me the full possibility of upgrading her. You are a savegame-saver :D
    – k0pernikus
    Mar 31, 2016 at 22:47
  • And in fact, I had all three Inspirational perks and I only needed to remove the 2nd one.
    – k0pernikus
    Mar 31, 2016 at 22:50

If you encounter the glitch where you can't access Ada's parts, when you just see the legs in Workbench, you need to the console and choose Ada with a pointer and run recycleactor.

(From an attempt to edit in another answer into the main question: https://gaming.stackexchange.com/review/suggested-edits/310142 )

  • This was the one that solved it for me, but in addition while I still had Ada selected I also ran moveto player so that I could then put her in the workbench.
    – Sean
    Jan 2 at 23:51

This seemed to work fine, for me:

completeallobjectives 01000801

SetStage 01000801 2900

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .