Sometimes during the map restart, when there are many people joining blue or red team, I usually meet the bug when I choose a team to join, but it fails (due to too uneven number of players probably), and when I try to choose a team again, nothing happens - pressing , or . doesn't work - neither class menu nor team menu is appearing, and all I see is the map aerial view with scoreboard. The only thing to do is to re-connect to that server (which is not always possible if the server is full and you're still connected but 'stuck', so no player slot is available).

How to avoid this or how to prevent, or how to recover from such a bug?

  • "Asked 4 years ago"?!? Valve should have fixed this by now :((
    – Christian
    Commented Oct 19, 2015 at 19:13
  • @Christian Busy with Half-Life 3, obviously ))
    – mbaitoff
    Commented Oct 21, 2015 at 7:25

3 Answers 3


In order to avoid it I suggest to not try entering more than once in the door of specified team, if the first time fails selected random.

Anyway, if it happens that you got stuck, you can easily recover from this bad situation by opening console and write


Retry command force a server reconnection and you access again the team selection screen. Sometimes, on busy servers with many people try connecting, this command causes to lose the slot.

For this reason, as suggested by @Dave McClelland in comments, is preferable use the command


because it fix the problem without forcing a re-connection.

If you really want to join RED or BLU team and reduce the probabilities to trigger that annoying behavior, I suggest to wait that half or more users on the server choose their own team, and then try enter your desired door.

  • Well, if I want to select a specific team, that won't help - I just have to try entering that team continuously until it succeeds. However, the idea with retry is very promising - gonna try it today. By the way, was this bug ever reported to Steam Support, - is it a "by-design" behavior or indeed a bug?
    – mbaitoff
    Commented Jul 13, 2011 at 9:02
  • Sometimes even retry doesn't guarantee you your slot. I tried this on popular servers and I get kicked out with "Server is full." That said, it works much of the time.
    – BoltClock
    Commented Jul 13, 2011 at 9:11
  • 1
    @Drake I have found people say that executing spectate in the console unsticks you from the "limbo" and puts you in the spectators class without the need of reconnection. Gonna try it also.
    – mbaitoff
    Commented Jul 13, 2011 at 10:20
  • 2
    @mbaitoff Yes, spectate should work for you without forcing a reconnect Commented Jul 13, 2011 at 11:14
  • 1
    @Drake I don't want the rep, as the OP had already found that part of the answer for himself by the time I commented. Feel free to add it to your answer once you confirm Commented Jul 13, 2011 at 12:17

I think it may be related to maximum team number on server for MvM matches and also the robots being regarded as opposing team members (auto_balance / team_balance issue related issue [supposedly... :P])

I had this problem non stop every time I started tf2 for all attempted connects to tf2 MvM matches. Normal matches were fine. I have found that by joining servers that have 5 or less players resolves the problem for MvM (for me anyway) if more players join the server (5+) the problem does not reproduce, you can remain on that server with map changes and player increases and the bug does not reoccur.

As the default for server maximum team for MvM matches is 6, joining a game with 5 players or less guarantee's a spot (in theory..) despite how ever many bots / robots their are :) I would say this is a bug that valve should look at, not that I cbf submitting it myself (lol) A simple man with simple goals. Hope this helps someone. If it doesn't, I apologise.

PS: I forgot to add, none of the above commands worked for me. All they did was what they describe.. (eg spectate, retry) with same results. Good Luck!


Just type in console: jointeam [red/blu/spectate]

  • Have you tried this yourself?
    – mbaitoff
    Commented Dec 14, 2013 at 9:24
  • Yes i did do that. and surely it works
    – ALOIYD
    Commented Dec 14, 2013 at 16:02
  • Sorry for the bump. I am commenting here just to say the issue still exists and this is the solution that works best for me. Much better than reconnecting, and sometimes the bug still persists after a retry. This is the only one that solves for me.
    – Olimon F.
    Commented Oct 5, 2016 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .