1

I recently bought a Steam Controller and it works very well with all the Steam games and features. Some days ago I bought FIFA16 and, as you probably know, it is an EA game accessible only by Origin.

I'm really struggling to get the steam controller to work properly with FIFA16. I already added both origin and fifa16 as non-steam games and I also made sure to uncheck conflicting origin settings.

The problem is that, even if I managed to use the most voted controller configuration on steam (big picture), when I get into the game and I start a new match the commands won't work. Also, I can't change them from FIFA16 and FIFA16 doesn't see my Controller, it just sees mouse+keyboard or only keyboard.

How can I solve this?

2
  • Steam controller worked with fifa 16 until a month ago, obviously adding the game launcher as non steam game, but recently amd drivers and steam client have been updated, and now for a reason the controller doesn't work
    – Roran
    Commented Apr 14, 2016 at 21:01
  • Have you taken this up with Valve customer care? If not, I suggest you do that as well.
    – SoundStage
    Commented Apr 21, 2016 at 8:51

2 Answers 2

3
+50

For this problem there is a workaround.

  • In Origin-settings disable origin-ingame(the overlay)
  • shut down origin
  • add fifa16.exe from your installation directory to steam via "add a non-steam game to steam"
  • start the recently added fifa16.exe from Steam.

Now the Steam overlay should work ingame and you can setup your Steam Controller

6
  • I previously tried that and still won't work. The game starts but I cannot setup my controller. Fifa16 recognizes it as a keyboard or keyboard+mouse. Thank you anyway.
    – AndreaM16
    Commented Apr 19, 2016 at 8:07
  • Was Origin turned off, when you started the game via steam and are you sure, you used the manualy added shortcut in steam? Also you could additionaly try to start steam with admin rights and re-install the controller drivers (go to hardware manager -> controllers and uninstall it, then re-plug the connector)
    – Otto V.
    Commented Apr 19, 2016 at 8:11
  • Yes, I made sure to turn Origin off but, when I lauch fifa from steam, it also opens origin and I manually close it. I'll give a shot to trying it with admin permissions and resistalling the drivers and I'll let you know. Thank you.
    – AndreaM16
    Commented Apr 19, 2016 at 9:49
  • Try first to let origin open, once it's started via steam.
    – Otto V.
    Commented Apr 19, 2016 at 9:50
  • Nothing, it does not work.
    – AndreaM16
    Commented Apr 19, 2016 at 15:40
2

See this comment on Steam Community Forum.

Basically what the poster suggests is to turn the steam controller desktop settings to an XBox controller.

The settings the poster is talking about I believe are here: Big Picture mode -> Settings (the gear symbol at the upper right) -> Controller (category) -> Configurations -> Desktop Configuration.

I do not own a Steam Controller myself, so I can't really check if this works though. Keep in mind you will lose the keyboard and mouse support with this setting on.

Please let me know if this worked.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .