2

I installed nethack on ubuntu via the terminal using

sudo apt-get install nethack-common nethack-console

For some reason I can't use CTRL+P to display message history. I've tried putting on and off caps lock, tried CTRL+SHIFT+P, and even CTRL+ALT+P and nothing works. All it seems to detect is the SHIFT-P and asks me what I want to put on.

  • Why is this rated down? This seems like a perfectly valid question to ask and I have tried everything... – Douglas Newton Apr 19 '16 at 17:31
  • 1
    I'd presume either the key isn't set in nethack itself (check ~/.nethack.rc iirc) or something is grabbing the ctrl+p key combination such as the terminal and doing something with it. – djsmiley2k Apr 19 '16 at 17:38
  • @DouglasNewton I downvoted as it does not appear to be on-topic as gaming relate; at first glance it looked like it belongs on a different stackexhange site. I apologize if I was mistaken – Wondercricket Apr 19 '16 at 17:40
  • @djsmiley2k I think you are right. BASH seems to use ctrl-p for command history. I tried running it in the xTerm but it won't work either (and looks terrible in comparison). My bad, I know BASH isn't a terminal but I switched terminals to try nonetheless (and since both run the same shell they would have the same issue). – Douglas Newton Apr 19 '16 at 17:51
  • 1
    @Wondercricket I understand - nethack sounds more like a network utility than a game, but it is definitely a game and one worth trying ;) – Douglas Newton Apr 19 '16 at 17:53
1

It turns out CTRL-P was in fact working, but not in the way I expected.

The tty version of nethack displays a list of recent messages on the right side of the screen when using the command - so this is what I was expecting it to do. However, The offline version simply repeats the last message (or the ones prior to it) at the top of the screen.

Because I was trying different CTRL, SHIFT, P combinations, I obviously used the put-on command ( SHIFT-P) at least once. Then when I tried CTRL-P, the command was doing its job by displaying a recent message but it looked like it was merely interpreting it as another put-on command. Of course, I realised my mistake when I did other actions in the game which displayed different messages and tried CTRL-P again.

EDIT: As hobbs pointed out, I hadn't set msg_window to full (alt.org usesreversed) and therefore wasn't getting the functionality I was used to when playing on the server.

I had to create a new configuration file, ~/.nethackrc with OPTIONS=msg_window:reversed and everything worked as expected.

  • 1
    Setting the msg_window option in game or in ~/.nethackrc to one of the other options besides single, probably full, will give you what you're used to. What you're playing is the tty version, just with different option defaults. – hobbs Apr 20 '16 at 3:32
  • @hobbs Thank you so much, this is what I needed. I created a ~/.nethackrc with OPTIONS=msg_window:full – Douglas Newton Apr 20 '16 at 6:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.