I have placed a powered rail on a slope with a redstone torch underneath it as shown in the following two pictures.

Redstone torch under rail

Powered rail unpowered

Now as you can see, the powered rail is in fact unpowered, despite the redstone torch underneath it.

However, if I place a redstone torch next to the powered rail it is powered, but when I remove it, it continues to remain powered, as it should have done in the first place.

Redstone torch next to powered rail

Powered rail powered without redstone torch

Is this a glitch? Or some behaviour of redstone/minecart tracks that I am unaware of?

  • Try removing two blocks from the left side of the powered track so that the original torch can "breathe". See if it exhibits the same behavior. I know redstone torches have behaved strangely for me when I completely surround them.
    – user9983
    Commented Jul 17, 2011 at 5:56
  • Hmm I tried that but it doesn't appear to work. It doesn't appear to be a "breathing" problem here. Commented Jul 17, 2011 at 7:38

3 Answers 3


This is a glitch relating to the updating of blocks.

In short, the issue is that when the powered rail is placed, it does not check to see if the block it is on is already powered, but keeps its state until a nearby block updates, such as might happen when you place a redstone torch that would power it.

When that redstone torch is removed again, the track checks to see if it still powered, and, realizing that it is, stays on. (c.f. the glitch that would give free power to tracks placed on a slope when one was removed from a chain of powered rails).

Anything that causes the track to be updated should make the track powered; such as placing the tracks sequentially from bottom to top, meaning that the initial state of the powered rail will be flat: When the next rail is then placed, pulling the end of the powered track up, it updates and gets power.

Another alternative, as Dan F mentioned, is to simply place the torch after the rail.

  • Ok, but this only appears to occur on slopes. Doing the same thing on flat ground (a redstone torch under the block the powered rail is on) powers the rail straight away. Commented Jul 17, 2011 at 11:52
  • Ah, that makes sense. Ta!
    – Dan F
    Commented Jul 17, 2011 at 13:55

I don't know if this counts as an answer per se, but I've had this happen to. Not all the time, just occasionally. I'm pretty sure I fixed it by digging down from the side and placing the torch under the block + rail, rather than placing the torch then placing the block + rail.

  • Yeah that works for me also. Any idea why it is necessary though? Commented Jul 17, 2011 at 7:37
  • @DanielL Nope, no idea. Completely threw me the first time it happened. Hopefully someone who knows what they're talking about will answer :-)
    – Dan F
    Commented Jul 17, 2011 at 8:05
  • @DanF: Happy to help. ;) Commented Jul 17, 2011 at 10:22

If you want this powered permanently, you could try using redstone blocks instead. I haven't tried this on a slope like this, but I typically power powered rails this way, in no small part because redstone is so plentiful.

Also, isn't this an example of a NOT gate?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .