1

I recently wanted to make a force field so that some players can't access the area above this force field, and for this, I've made this command (on picture) and here is what it says: enter image description here

I don't understand what is wrong in my command; unless it is the system ?

enter image description here

2
  • 3
    I see you are playing 1.9. Please remove the redstone clock and set the command block to "repeat" instead. This way, you prevent redstone lag, which can cause problems if you have a lot of clocks like this.
    – MrLemon
    Apr 22, 2016 at 17:08
  • Thank you very much for this, it is real that I hate redstone lags :)
    – Kimatuy
    Apr 23, 2016 at 0:49

1 Answer 1

4

It looks like your command is /tp @a [x=-3,y=1,z=0,dx=-9,dy=7,dz=0] ~ ~ ~-1

I see one error with this: you need to have the @a and [ touching.

Fixed command:

/tp @a[x=-12,y=1,z=0,dx=9,dy=7,dz=0] ~ ~ ~-1

7
  • 1
    Your second point is incorrect; delta parameters may be negative and 0.
    – Skylinerw
    Apr 22, 2016 at 17:07
  • How do they work with 0?
    – Angelica
    Apr 22, 2016 at 18:03
  • 1
    It targets players at the same blockspace as the specified coordinates. Otherwise it's the number of blocks in the specified direction from the coordinates (such as a value of dx=1 encompassing 2 blocks; the origin and 1 block in the X direction).
    – Skylinerw
    Apr 22, 2016 at 18:05
  • It going ever worse; the little line that appear after the command is run don't even do now (I'm not saying for the comment but for the answer)
    – Kimatuy
    Apr 23, 2016 at 1:02
  • If I understand your complaint correctly, then I, too, encounter this problem. It seems to happen only on command blocks set to 'always active'. try setting it to impulse on a clock, and see if that works.
    – Angelica
    Apr 23, 2016 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .