I just bought a Netgear router 'WNR1000v2'. My PSP can scan this wifi connection but when it tries to connect it says

A connection error has occurred. Check the security settings for the network and try again.

I googled it and found that there are lots of guys facing the exact same problem, but could not found the solution. I tried everything but of no avail.

At present i run my router @ 54mbps as suggested by few forums, and using no security.

P.S. Using this router i can access the wifi connection on my Desire S,

3 Answers 3


What type of encryption do you have on your router? PSPs may not support newer encryption protocols (WPA2). If use an older protocol like WEP or WPA, you may have better luck.

Edit After some quick googling, I found this article which may provide some insight. It seems WPA2/AES doesn't work, but you can use WPA2/TKIP-AES. Check your router's administration settings and you should find an option to change this.

  • ah! this is not working :( Jul 24, 2011 at 6:50
  • He said he is running no security.
    – Resorath
    Jul 24, 2011 at 8:27

You mentioned that you're running it at 54mbps which is the 802.11g (note the "g") standard. According to this, the PSP only supports 802.11b.

So, you'll have to go into the configuration of your router and change it to 802.11b or, if it supports dual band, 802.11b/g. Unfortunately, if your router doesn't support both at the same time, you'll have to use the older, slower one (802.11b).

As was mentioned by Dave McClelland, the security method is also important, however if it is open as you say, it shouldn't be what's stopping you.

If you need to figure out how to change it, I believe there's a copy of the manual here (under Documentation).

  • This is correct- Usually on the PSP open wont work.. but if you use WEP on WIFI b.. Then you should be able to connect. Make sure to reboot your router after the config saves.
    – Piotr Kula
    Jul 25, 2011 at 13:13
  • That's not true. you can connect with the PSP to an unprotected network.
    – Trefex
    Jul 26, 2011 at 10:45

The PSP runs on an 802.11b network. If you are running your router exclusively in 54Mbps mode, that means 802.11g. I have found that even running pure 802.11g networks sometimes my PSP can scan them, but not connect.

If you are not running any security, you should be able to connect your PSP to your wifi network. Commenters on a previous answer mentioned you can (or cannot) connect to an unsecured access point. I have found that there is some credibility to this. I have had issues in the past, connecting to my own unsecured AP. It does not happen in all cases however, and I would suggest that you TRY WEP encryption, if you're currently using unsecured wifi. Specifically WEP because it tends to have the best success rate with PSP connections--again, this is just my experience. WPA has worked for me, but WEP tends to work more smoothly. Additionally, as a troubleshooting step, you may want to try "b-only" mode, if your router has it. I do not recommend staying in this mode, but some devices use mixed mode in an imperfect manner, and it can cause issues with older b-wireless devices.

The PSP's networking is pretty flawed, to be quite honest. There are a lot of (disappointing) shortcomings, in my opinion, but there is no real reason why your setup SHOULDN'T work, as is.

Good luck to you.

  • 1
    Most modern routers are capable of running WPA and WPA2 at the same time. So there is really no reason for running WEP which can be hacked within a couple of minutes. if you live in a big City you want to avoid WEP like it was Ebola. Mar 25, 2014 at 17:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .