When you enter the main Rocket League Window.

enter image description here

You will notice I have a Yellow Exclamation Mark under Garage Menu Link.

But when you enter the Garage Menu, Nothing is there for me to highlight or check???

enter image description here

Am I going crazy? or is this a bug of some kind?

Edit: Issue has been going on for months.

  • Possibly try restarting the game completely, if you haven't tried that yet
    – Jaconah
    May 4, 2016 at 16:22
  • @jaconah What are talking about? How do you restart a game semi-completely? This has been an on going issue for many months. May 4, 2016 at 16:27
  • you did not state that has been going on for months, so I just suggested the first thing I always do whenever a stupid error like that comes up
    – Jaconah
    May 4, 2016 at 16:29
  • 1
    I've had this bug for a very long time, as well. Ever since they had a sale and I bought a bunch of DLCs, I've had the issue, so it's not just you.
    – KOVIKO
    May 6, 2016 at 5:34

7 Answers 7


1) Disable Steam Cloud Save:

  • Open Steam
  • Click on the "Library" tab
  • Right-click "Rocket League" then click "Properties"
  • In the Properties window click the "Updates" tab
  • Under "Steam Cloud" un-check "Enable Steam Cloud synchronization for Rocket League"
  • Click Close

2) Delete Local Save:

  • Open My Documents\My Games\Rocket League\TAGame\SaveData\DBE_Production
  • Delete both ".save" documents *NOTE: This will remove all customization! This includes graphic settings, vehicle presets, and any UI changes! It will not remove any items / vehicles that have been acquired.
  • Close the window

3) Start Rocket League

  • Verify that all the customization options have been reset (and the yellow exclamation point is gone).

4) Exit Rocket League

5) Enable Steam Cloud using the procedure in Step 1.


Each car has various paint jobs that are unlocked as you play the game. They will not show as "new" with the exclamation point until the appropriate car is selected. Select each car (equipping it), then move to the paint job tab to see the new paint jobs that are unlocked.

  • 2
    I think another exclamation point will show up on the Body page next to any cars that have new paint jobs unlocked, and there aren't any shown in the screenshot provided. May 4, 2016 at 20:27

Select every car and go trough all the tabs. It's something unlocked for another car.

  • I did, I went through every single car. And found nothing that needed to be highlighted. May 11, 2016 at 4:49

It's a bug, I have all the DLCs that come with the game, and I have everything checked out, just like you. But the exclamation point is still there. I still don't know why they haven't fixed it. Maybe no one has reported it, who knows? But I know for sure that it is a bug.

Edit: Check every car and every decal on it, since all cars unlock new decals and it doesn't put an exclamation point on it.

  • I have checked each section, many times. May 17, 2016 at 18:46
  • Hmm... For me checking very Decal and Paint Job on every car fixed it for me. Are you sure you've checked both?(Sorry for the late response. This month's been hectic for me.
    – Sain
    May 28, 2016 at 22:28
  • 1
    btw, the only reason you got the +25 was because it randomly picked you, I didn't pick it. May 29, 2016 at 5:27
  • Well can you atleast tell that it fixed it for you? Have you tried?
    – Sain
    May 31, 2016 at 13:38
  • Even with the new update, it's still there. Aug 23, 2016 at 18:26

It probably has something to do with the new NBA adds. Have you tried navigating through all the tabs to see if there's something new that might not have been "marked"?

  • Yes, I have already. And this logo has always been there before the NBA logos were even added May 4, 2016 at 16:20

I had this issue for a while, the problem was that I had unlocked the Royal decal for the Dominus (a DLC car that I did not have).

The way I fixed it was going onto the Manage Inventory tab in garage and scrolling through the items until I found it, then hover over it and the exclamation mark was gone.


It apparently is DLC-related, though the specific culprit seems to vary from person to person. Some people have had success by doing this:

  1. Close the game (if it's open).
  2. Go into your Steam library and uncheck/disable all the DLC.
  3. Open the game, then close it again.
  4. Re-check/re-enable your DLC.
  5. Open the game. It should hopefully be fixed by this point.
  • I've never purchased any DLCs. So I have nothing to check or uncheck. May 17, 2016 at 18:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .