9

I keep getting these error messages on my minecraft server. A couple times every minute in fact. I am running the server on 4Gb and have a total of 8Gb. The world is vanilla and usually does not have more than 3-4 people on it. I am running it on the same computer as I play Minecraft on but the error message comes up even when I am not online or have Minecraft open. I am running the server on 1.9.3-pre3. I have lots of command blocks in the spawn chunks to add some stuff to the game but there is not more than 62 command blocks in any of the spawn chunk as I know that can cause lots of lag. Any ideas as to how to get rid of this error message and reduce lag (lag includes mobs moving really slowly and block lag is not uncommon) enter image description here

  • Possible duplicate, but not quite sure, so I'm not voting: gaming.stackexchange.com/questions/125849/… – Frank May 6 '16 at 22:07
  • I use a Windows 10 operating system. – EJ_BlackFire May 6 '16 at 22:29
  • Im using a modded server and relating to this problem, i figured that "plugin loaders", such as spongeforge, could decrease the chance of the server having to skip ticks. Also its not highly confirmed that "plugin loaders" or certain mods can fix that issue. The mods or "plugin loaders" that claim they can help with server-side performance use special blocks of code in which I call, "accelelators", which can impact client performance while helping server performance. As an example, plugin loaders like craftbukkit and spigot contain accelelators which borrow your extra/reserved GPU and memory s – PTBUSE Sep 2 at 15:38
6

If your players are moving quickly through new terrain so that the server has to create lots of new chunks this can happen. For example, one way to aggravate this issue is to get several players riding horses through previously unexplored territory.

The issue can be aggravated by having players that use client-side cheat mods that let them travel super fast. I have watched a Minecraft server crash because a player was running so fast through previously unexplored territory that the server started reporting being 10s of thousands of ticks behind.

One side effect of the server losing ticks: A player may break a block, only to see the block re-appear. I have played the game with a server console open and have noticed that when the server is lagging badly, sometimes I might have to dig the same block multiple times to actually get the block in my inventory.

In my case, I only had 3-6 players on the server at the time. The server is installed in a virtual machine, and I was able to reduce the occurrence of the problem by giving the virtual machine access to more processor cores.

Another mitigation technique is to convert the server to a Bukkit/Spigot server and use a mod called NoCheatPlus. It is able to prevent players from using client-side cheats that let them move faster than the game intends for them to move. I found it relatively easy to convert my server to a Spigot server and to import my existing world into it.

Though broken blocks re-appearing as if not broken is a specific symptom, from a better perspective, what appears to happen is that the client allows the player to perform some action and assumes the server will keep up, but then the game "rewinds" as if the action occurred during the lost ticks lost on the server. As a result, lost ticks can manifest in various other ways (i.e. a walking/running player may warp back to a point where they were previously located).

  • This seems to be the reason we got kicked from our heavily modded server. I found mods @ curseforge that help with this problem: MovingQuickly, mtqfix and Gotta Go Fast – arberg Aug 3 '18 at 15:40
1

Ok, so the server is just skipping ticks to catch up. This is not uncommon on personal computers. To get rid of this, you would have to get a better processor, or increase the amount of memory. You could also reduce the render distance that people on the server are using, allowing them to load fewer chunks.

0

I would suggest using Spigot or Bukkit, but since that is a little bit out of this realm, I won't go into that. (I was running a 10-11 person server with Spigot in 1.8, only using 1 gig of ram).

I would expect you would be having server amounts of lag, with the tick falling behind that much. Check the background processes on your computer,(you can do this with the task manager). If something is taking up a lot of processing power it would affect the performance rate of your computer. Try to minimize the processing power used when playing minecraft as well. (Keep render distances at medium, turn off fancy graphics, etc.)

Also be sure to keep the number of players allowed at a small number. It affects gameplay sometimes.

Not the answer you're looking for? Browse other questions tagged or ask your own question.