3

I've put about 7 hours into Arkham Knight over the past week but yesterday when I went to continue the game Batman just wouldn't move.

The player character doesn't respond to WASD, arrow keys, and the space bar is not detected as being held down (can't glide, but it does detect taps for the grapnel boost).

All the other keyboard controls work (gadgets, zoom, detective mode) and W, S keys can be used to navigate the menus so I can see that the game is receiving input from those keys.

I've tried:

  • loading a saved game
  • starting a new game
  • remapping the movement keys away from the default WASD or arrow keys
  • restarting the computer,
  • updating video drivers (currently installed GeForce 365.10)
  • verified local game cache through Steam
  • deleting BmEngine.ini and BmInput.ini config files and restarting the game
  • posted a support request to WB games (not holding my breath on getting a response...)

Searching around the internet I've seen reference to some sort of copy protection schema in Arkham Asylum that disables some controls (e.g. Batman won't glide) so you can't play the game - I'm wondering if AK has a similar thing and it's triggering a false positive?

I bought the game on Steam and have been playing it for the last week without problem so I don't know what's going on.

Does anyone know if it pings back to a server to verify the game? I've checked my firewall rules and AK isn't listed anywhere.

The only other thing I could possibly think of is that I'm running the Windows 10 Pro Insider Preview build 14332 (released 2016-04-22), but I checked the install date for my system and I bought and installed the game after updating to this build of Windows.

Has anyone experienced anything similar or know of a fix?

2

I have worked out the issue and it was my own fault.

I forgot that I was running the Synergy keyboard/mouse sharing application. It turns out the synergy server was receiving the keyboard input and trying to send it to another machine on my network.

Turning off the service got the game working as expected (it's just weird that only some of the input was being sent off to the other computer...) - good to know if it ever happens again though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.