2

I'm trying to play a game - Towerfall Ascension - through an HDTV with an HDMI cable, but the audio is not outputting through the TV when I try to play fullscreen. However, when I switch to window-mode the sound plays as it should through the TV. This behavior is seen with some other games too (Castle Crashers, etc) and other audio sources such as YouTube play normally through the TV. Any ideas why windowed games work while full screen games don't?

The game is using the Intel Integrated graphics.

Specs: MSI GS60

NVidia GeForce 860M

Intel Integrated Graphics 460

Intel i7-4710HQ 2.50 GHz

Windows 10 64-bit

Thanks in advance!

  • Have you set the default audio output as HDMI? Search "Manage audio devices" and make sure the default output device is your TV. – MC ΔT May 14 '16 at 13:59
  • Hi I'm the original poster. I did set the TV as the default sound output, but the full screen game still plays only from the laptop speakers - the green bars only show on the native speaker. – user147439 May 14 '16 at 20:14
  • I did set the TV as the default sound output, but the full screen game still plays only from the laptop speakers - the green bars only show on the native speaker. – Aleck May 14 '16 at 23:12
  • I have exactly the same problem. If anyone finds a way to resolve this, it would be great :) – mdzh Jun 23 '16 at 19:12
  • I have a similar problem with audio output switching from headphones to my monitor when I go fullscreen. I have disabled all audio playback devices except for headphones and it still happens. – Ergwun Oct 6 '16 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.