2

I've researched why it might be doing this, I have 450gb of free space and the save can't be too big because I've just started it, the disc doesn't seem to be degrading or have damaging scratches on it I've tried turning the auto save features off but it usually takes a save and load just to get the characters to speak on the intro before I get my head chopped off any ideas?

1 Answer 1

2

When I play skyrim it doesn't freeze for me, it does lag when I'm further into the story becouse of how big the game is. Got a few suggestions make sure that the PS3 has at least 2G of free space. Turn off all auto saves in game option but should know that you will have to make own manul saves. Go into game data utility and delete all corrupted files, they should have the name corrupted. You can clean the disk as well. If no improvement if could be a bad disk but again skyrim is a highly detailed game. Hoped it helped I'll continue researching it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .