2

I want to give myself a filled_map with data value 0, i.e. the very first map I would have ever generated.

I have tried:

/give @p minecraft:filled_map:0

which outputs the error: There is no such item with name minecraft:filled_map:0.

I have also tried:

/give @p minecraft:filled_map 1 0

Which I'm assuming used to work in earlier versions of the game because of this other question.

However, that command just gives me the next map in sequence (so if I am currently at the map with ID #0358/16 it would give me the map with id #0358/17, not the #0358/0 which I want.)

Please, I need to know how to fix this. Maybe there is an attribute I can set in the data tag? I.e.

/give @p minecraft:filled_map 1 0 {mapNumber:0}

But I do not know if such a thing exists.

  • The second one should have worked, but maybe the first map is 1, I'm not certain – Unionhawk May 19 '16 at 16:56
  • I tried with 1 as well, same problem (it gives me the next map in sequence) – theonlygusti May 19 '16 at 17:02
  • @Unionhawk I think the first map is 0 though – theonlygusti May 19 '16 at 17:02
2

Hah hah! I figured it out.

Turns out, I'd been messing around too much; this command is the one which works:

/give @p minecraft:filled_map 1 0

The problem is (was) I had deleted map_0.dat from my data folder; I had wanted to replace it with another image, so I thought I should delete it to re-generate it afresh, however the way I should have gone about it was just placing my custom map files into the folder before trying to generate them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.