5

Recently, Kerbal Space Program had an update. Since that update, several buttons and options are not visible anymore.

For example, the in-game settings are not shown: Missing in-game options

And at the vehicle assembly, the buttons (for selecting "Engines", "Structural", "Pods"...) are invisible: No buttons to select parts

Likewise, no astronauts can be selected, the list is just empty: No astronauts can be selected

I'm running KSP on Ubuntu 16.04. Removing all Steam/KSP files and doing a clean reinstall has not helped in any way. Do I have to wait for the next update?

Additional information: The bug disappears now in 1.1.2 (fullscreen mode and low screen resolution). Using my full screen resolution of 1366 x 768 and fullscreen, the bug re-appears.

3

If removing/reinstalling the game ends in the same result, it's likely a bug on that platform. Go to the Squad website and submit a bug report, giving as much detail as possible, including screenshots, and your system information and steps you took to reproduce the problem.

You can also try to revert the version on Steam until a patch is released. I've not done this myself, but I hear of others doing it when game updates introduce unplayable bugs.

You might still try updating your graphics drivers too. If you play in 64-bit mode, try the normal 32-bit mode to see if you have the same issue. (I saw some weird behavior in the 64-bit version that I didn't see in 32 bit.)

  • I've already tried the 32 and 64 bit versions, and both have the same problems. Now, I try Steam Library --> Kerbal Space Program --> Properties --> Betas --> Previous stable version. – user258532 May 24 '16 at 11:28
  • KSP 1.0.5 (64 bit) does work without these problems, indeed. I now file the bug. Thanks for your assistance! – user258532 May 24 '16 at 22:00
  • Glad to hear it's worked for you. If you feel my solution has been helpful, consider upvoting and/or marking as answered. Thanks! – Tim S. May 25 '16 at 0:18
  • I have added more information above... – user258532 May 25 '16 at 9:04
1

It's probably problem with compatibility with Unity 5. Try to read this: http://forum.kerbalspaceprogram.com/index.php?/topic/137849-ksp-does-not-show-any-menu-content/

1

This is an issue with Unity's GUI functions and the Linux Mesa drivers.

To fix it, delete your config file, and then load KSP through the launcher,and use the nearest standard resolution

To give you an incomplete list of common valid resolutions: Widescreen: 1280x720 (i.e 720p) 1920x1080 (i.e. 1080p) Narrow Screen: 1024x768 (i.e. 768ni XGA/XVGA)

Known NOT to work: 1600x900 (i.e. 900p/HD900)

There are probably more resolutions that work, and if someone knows one that does, be sure to reply to my comment with it.

  • Yes, I remember that KSP 1.1.2 (64 bit) didn't work when using the full screen resolution, but a lower one (1280 x 720, I remember) worked. Although I use 1.0.5 for the time being, let me thank you for your reply! – user258532 May 30 '16 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.