1

This just started happening today, so I assume it has something to do with Update 7. When the Worker picked up the Bed from Storage, this happened. When I tried to get a screenshot, it disappeared. It popped up a few seconds later.

Is this just a bug, and is there any way to fix it?

  • Does it actually get installed that way, or just while the worker is carrying it? – Tim S. May 27 '16 at 21:47
  • @TimS. It looks like it's just while being carried. – rivermont - Will B. May 27 '16 at 21:50
  • Looking at the materials.txt file there does not seem to be anything obviously off about it. No sprite scale at least. Do you have any mods on? If so, try turning them off, especially those adding graphics. – Sumurai8 May 27 '16 at 22:23
  • Nope, no mods. I have edited the save file a few times, but only the Balance value (bugged money). – rivermont - Will B. May 27 '16 at 22:25
  • Actually, I reproduced it in my save file. Hrmm... what did they do... – Sumurai8 May 27 '16 at 22:26
3

After comparing the old and the new game files, this issue was likely introduced in the actual executable. No changes were made to the "Bed" sprite or object, nor the "Box" sprite or object between update 6 and 7. As such, we can't mod the game to fix the bug.

I have filed bug #10863 with Introversion. The actual issue seems to be with any object that has a height, that is carried, and is rotated 45 degrees to the left.

  • Glad to hear this - I recently also had this again with a regular door, so this definitely corroborates what you mentioned. – Tim S. Jun 2 '16 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.