2

I just bought the Intel NUC Skull Canyon (NUC6i7KYK) with the latest Iris Pro Graphics Card (580). As this is supposed to be a Mini PC for gaming, i expected FIFA 16 to be working. But unfortunately it is impossible to play, since all players are rendered black. Does anybody have an idea?

I tried all various display configurations, but none was working. I am using Windows 10 64 BIT. Any help is appreciated.

enter image description here

enter image description here

enter image description here

7
  • They look ok to me. Isn't it just shading on their playermodels?
    – imulsion
    Jun 3, 2016 at 7:26
  • exactly, with most of the display configurations of fifa they are completely black. the best it gets is with a frame rate set to "no limit on fps". this is the picture you see above. but players are still to dark to differentiate. Jun 3, 2016 at 7:35
  • actually I reinstalled the intel drivers yesterday. after playing around with all the display configuration settings on fifa, it turns out they are still too dark to play, but not anylonger completely black. the issue remains :-( Jun 3, 2016 at 7:46
  • Have you tried adjusting the lighting/shadow settings in game?
    – imulsion
    Jun 3, 2016 at 7:47
  • is there a setting like this in fifa 16? do you mean "video calibration"? Jun 3, 2016 at 7:56

1 Answer 1

0

It seems there were driver issues, a couple of days ago intel published a bunch of new drivers. now it works: https://communities.intel.com/thread/102774

Update 1

Just to make clear - this thread is about NUC6i7KYK with Intel Iris 580. With latest drivers it is working. Another user mentioned that this issue remains with Iris 550. So don't down vote if it not working on other intel graphics!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .