4

I have used the Stellaris launcher to add a mod to the Steam workshop for the game of the same name, but after doing so, it appears with a blank thumbnail:

enter image description here

Going from the steam side of things, you can manually upload an image, but there doesn't seem to be an option to select it as the thumbnail:

enter image description here

I can't for the life of me seem to find anywhere to actually set the thumbnail. The in-game upload screen seems to be lacking this as well.

enter image description here

Is this something doable in-game, or is there some workshop setting that I'm missing? (There definitely are mods for this game with thumbnails)

3

I'm sure by now you solved this, but I'll leave here my answer for others that may encounter this issue. I had this issue too with my mod http://steamcommunity.com/sharedfiles/filedetails/?id=811654002 and didn't find any help elsewhere, but I sorted it out.

Make sure you add the thumbnail tag picture="picname.png" in the yourmod.mod file, not in the descriptor.mod file located in your mod folder.

  • What folder does picname.png go in? – Aaron Franke Jul 7 '18 at 15:00
  • @AaronFranke It goes in your mod folder. – Alina Jul 19 '18 at 12:42
0

The game wiki has a rather detailed guide that explains this too: http://www.stellariswiki.com/Modding#Mod_structure. There also is a section specific to the Steam Workshop, but is not relevant in this case.

-2

for others who find this make sure its 400 by 400 in pixel size or it wont work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.