3

When I'm playing Overwatch, sometimes the crosshairs will disappear, or they will show up as a large black box, or there will be hero portraits or health bars covering them when they shouldn't be. Below is an example of crosshairs being obscured:

enter image description here

Also, when at the hero selection screen, sometimes the hero portraits will be missing, or will display the incorrect hero, as shown below:

enter image description here

enter image description here

I'm using 2 GTX 980 graphics cards in SLI. I tried setting "Force rendering profile 2" under SLI settings for Overwatch in my NVIDIA control panel, as suggested on some forums and Reddit, but it hasn't resolved the issue.

I have my graphics settings set to Epic in Overwatch.

  • I had a similar issue which was fixed by disabling amd crossfire. Make of that what you will. – Studoku Jun 12 '16 at 23:04
2

I tried downgrading my graphics settings in Overwatch from Epic to Ultra, and it resolved all of the issues with the disappearing crosshairs and incorrect portraits.

So I suspect that one or more settings under Epic is what causes the issue, but I haven't experimented to pin-point which settings those are exactly.

  • I have problems sometimes with not being able to see any heroes for a bit once I start a match. I suspect that the graphics are a little intense for my card. I plan to upgrade it soon though. – Dragonrage Jun 13 '16 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.