0

So I got one of these controllers back in December (2015) and have had no issues until now. The usb cable it came with was garbage, would always disconnect when moved the wrong way, which if you game like most of us, it gets moved a lot.

I managed to add some tape to the plug to better fit it but still it would disconnect now and then. Today, it disconnected again only to immediately reconnect while I was hitting many buttons, (forza 6 drifting) and then it went into factory reset mode, (which I did not know at the time that's what it was) I though it was just a glitch, so I quickly unplugged it, only to power it back up and have my earphones work but not the mic, RB RT and right stick weren't working either. Went online and found out how to factory reset it but my mic still won't work, I can hear and adjust chat volume, but the mic won't work. It works on my phone and pc just fine. It also registers a headset is connected when its not, making me unable to use my kinect with a controller connected.

Anyone run into this and able to solve it? Or am I gonna have to contact PDP?

1

Firstly, I would suggest forcing another factory reset. Sometimes "smart dumb" devices don't quite restart properly, so just try it again and see if it fixes your mic issues.

As for the controller functions itself, like your triggers and such, try using the PDP Afterglow Configuration app found on the App Store. not only does this allow you to program your controller easily (rather than attempting to use bit translation or some other form of IT voodoo) you can save multiple controller "profiles" to match different playstyles, such as driving, FPS, RPG, etc.

  • Ive reset it multiple times, everything works except the mic though. – Alex B. Jun 17 '16 at 1:51
  • @AlexB. have a look at this answer, which covers controller updates. Apparently on the XB1, controllers have updates as well. This answer advises that while running an update to connect any mics during the update. – Ben Jun 17 '16 at 2:35
  • This controller does not say "update" in the console settings like the original controllers, i tried. – Alex B. Jun 17 '16 at 3:42
  • The only way to update was when the app was released, and the first time you start it up it updates the controller. Factory reset does not remove this update either. – Alex B. Jun 17 '16 at 3:43
  • OK, one last hail mary then; did you try the reset with the mic plugged in? – Ben Jun 17 '16 at 3:44
0

I also had the same issue, and sometimes it appears again. But I’ve solved it by spamming the button that appears on the right side of the right joystick until it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.