9

I have a tablet with Windows 10 on it. It has an Intel Cherry Trail processor with integrated graphic card. I installed several games on it (Warcraft 3, C&C: Generals, NFS: Most Wanted, UT2004, DOOM 3, Flat Out 2, Counter Strike 1.6). While some of the games (Flat Out 2, NFS: Most Wanted, DOOM 3, Counter Strike 1.6) run fine, the rest of the games is trying to display in portrait mode:

Photo showing the issue

I have not been able to find out how to fix this. Only option is Windowed mode with Warcraft 3, but the tablet can't handle 2048x1536 resolution fluently, so I would have to change my desktop resolution anytime I want to play it. Also you can not really move around the map in the game by touching the side with mouse, as it is in windowed mode.

Funny think also is, that it displays rotated, but the controls (or touch input) reacts as it is displayed correctly. From my investigation it seems to be DirectX 8 related problem and that games that runs on higher DirectX are ok.

I also tried compatibility mode, disable scaling, different resolutions but without any success. Since I did not found the solution I decided to create this question.

EDIT: My girlfriend bought this netbook recently. It has the same processor as my Onda, so I tried some game on her tablet. I actually only tried Warcraft 3, but there was no problem with screen rotation. So it might be an error specific only to my ONDA tablet, or maybe I have some bad GPU drivers or something like that. Still no sollution though :(

Examples: enter image description here enter image description here Warcraft 3 can run in portrait mode: enter image description here

  • The screenshots show only Warcraft III. Can you give a list of affected games? – MrLemon Jun 22 '16 at 13:45
  • C&C Generlas Zero Hour, UT2004 will display like this for a second and then crashes. In the forum I posted (now it's just image) the author mentiones: "Such rotation issue found it: Warcraft III, Hitman Contracts, Thief Deadly Shadows." – Zdeněk Braun Jun 22 '16 at 13:58
  • have you tried to rotate the screen first, than start the game. ? – Rusted_Silver Nov 4 '16 at 8:33
  • I tried landscape mode and run the game -> game is displayed rotated 90deg, although controls works as it is displayed correctly landscape. I tried portrait mode (as you can see on the last picture) and the game displays ok, but you don't really want to play games in portrait mode. When I try to rotate the screen when the game is running, it crashes, but that depends on the game. Sometimes it stucks after the rotation, but if I rotate it back it unstucks, but still displays rotated. – Zdeněk Braun Nov 4 '16 at 8:40
1

With an external keyboard you could try:
+ Alt + or
to rotate the screen

  • Already tried that, but that just crashes the game. It really must be specific to this tablet/OS, as the game acts like it is displayed correctly (you can control it like it is displayed ok), just the rendered image is rotated 90 deg, but desktop behind the game is displayed fine. I think it might be due to the resolution of the screen, as everything is fine on a tablet with same specs, but only 1280 x 800 resolution. – Zdeněk Braun Nov 4 '16 at 7:55
  • that works with intel drivers and intel HD graphics – Fennekin Jan 16 '17 at 13:32
0

Unfortunately, no. These games are either not detecting the change of orientation or are not made to run in that orientation

  • It seems like it.... But isn't there any tool that can convince the game that current orientation is different? – Zdeněk Braun Jul 29 '16 at 9:54
  • Not that Is know of, unfortunately. – Nitrous Oxide Jul 31 '16 at 3:49
0

Try a wrapper, I know they are for setting window mode, but they are a modern implementation. So maybe running old games through one will scale and rotate properly. http://www.ghacks.net/2014/05/04/force-fullscreen-games-play-windowed-mode/ Might help...

Not the answer you're looking for? Browse other questions tagged or ask your own question.