2

In Rome 2: Total War, I often get a particular very annoying performance problem.

When in battles, especially with larger numbers of units, sometimes the battle will "lag". By this I mean that all moving objects (like units) will freeze in place for a few seconds. During this freeze, the game is not unresponsive: I can control the camera, but cannot select units or issue orders, and the framerate doesn't seem to drop from the usual 20-30 FPS I get. Even effects like waves and rain proceed as usual, just the troops stop moving briefly.

  1. Why is this happening?
  2. What graphics setting can I change to reduce it?
  3. What hardware component is the most relevant for this?

I have tried googling the issue, and found many other people with the same problem (and I'm hoping that many readers of the question will recognize it from experience). Unfortunately all the fixes I've found are useless.

Update: I noticed that switching to the lowest graphics settings doesn't make a difference, and if I switch to Very High I still get a good frame rate (but the stuttering remains).

  • Since i don't have much experience with total war games, is this happening in Multiplayer? If so it might just be normal because the game has to synchronize the players. – Benjo Jun 24 '16 at 6:20
  • @Benjo No, this is in single player. – Superbest Jun 25 '16 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.