The sounds in Minecraft will not work in any version of MC I have tried. Playing with mods, the mods' sounds will work but not the vanilla sounds. I have tried multiple things including:

  • Restarting my computer
  • Reinstalling Minecraft
  • Using the F3 key method
  • Looking at the sound files on my PC
  • Making sure MC isn't blocked by an antivirus
  • 1
    Have you checked the sliders in Options... -> Music & Sounds...? – SirBenet Jun 26 '16 at 19:01
  • you mean my volume in game yes its at max on all of them – Crimsongaming Jun 26 '16 at 19:40
  • all in game volume is at max – Crimsongaming Jun 26 '16 at 19:44
  • also forgot to mention I also previously took the .mc folder and put on my desk top and mc made s[a new folder which I put all the files on the date prior to the day in the new .mc file and kept all items that were the same and I just found legacy.json and a objects folder with a lot of file rather than having a black page thing with no name and that takes no storage at all in it and put those on just now – Crimsongaming Jun 26 '16 at 19:54
  • I have had this happened to me a few times. To fix it I reload my resource pack via f3+t in game. Not sure if it'll work for you but it is worth a shot. – LethaIity Jun 26 '16 at 20:57

Try checking if the assets directory in .minecraft has an indexes folder containing a JSON file for the version you are trying to play. If not try deleting the versions folder to get the launcher to redownload the game. If all else fails try deleting the assets directory.

  • Also check if the objects folder has about 250+ folders in there – SamboyCoding Jun 27 '16 at 19:41
  • I have jsons and my objects folder has them all – Crimsongaming Jun 30 '16 at 21:29

See if your volume in minecraft, on your headphones isn't too low.

  • of course its not I have it at max and my speakers are at least at 10-30 – Crimsongaming Jun 30 '16 at 21:32
  • and its at 10 because of loud mod mob sounds that are the mods own sounds so still I hear those – Crimsongaming Jul 1 '16 at 1:37
  • Do you have updated drivers? – BitCrack Jul 7 '16 at 21:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.