I have looked through many questions and have not found this, i would like to have it so the redstone activates once the player goes in a certain area, this is almost done but for some reason it is measuring the radius in chunks, not blocks, any advice?

Image of attempted command

I have tried everything, please help.


The m after r=2 is unnecessary and does not search for that number of chunks (thanks @Skylinerw). By adding it, the command block ignores the radius parameters and instead searches the entire world for the player. In order to search in a radius of 2 blocks, remove the m.

Your command should look like testfor @p[x=437,y=72,z=2363,r=2].

  • thanks a lot, ive been browsing so many forums and they all told me to do the m thing, but anyway it works now :D
    – Red202
    Jun 28 '16 at 19:54
  • 3
    No problem! Please let others with similar questions to yours find this answer by clicking the little check mark to the left of my response to accept this as the official answer.
    – Logikable
    Jun 28 '16 at 19:56
  • 2
    While removing the "m" allows it to work, it does not represent a number of chunks. It's just invalidated because it's not a number and thus the player is found anywhere in the world.
    – Skylinerw
    Jun 28 '16 at 19:58
  • My bad, I just assumed that was the case during my testing. I'll edit my answer.
    – Logikable
    Jun 28 '16 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.