This question already has an answer here:

I want to make a map but the /tellraw command won't work in Minecraft 1.10, not 1.9 or 1.8 just 1.10 it used to work perfectly in 1.8 as:

/tellraw @p {text:"what ever you want",color:red,bold:true,underlined:true,clickEvent:{action:open_url,value:"a url"}}

How can I fix this?

marked as duplicate by GodEmperorDune, Ave, Ben, Skylinerw, Frank Jul 1 '16 at 2:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What was the last version it worked on + what is the complete command? – Ave Jul 1 '16 at 0:46
  • it work on 1.8 and the command is /tellraw @p {text:"what ever you want",color:red,bold:true,underlined:true,clickEvent:{action:open_url,value:"a url"}} – TARDIS_FREAK Jul 1 '16 at 1:30
  • no that not it but thanks – TARDIS_FREAK Jul 1 '16 at 1:48
  • 2
    Actually that is the answer. – Ave Jul 1 '16 at 1:55
  • 1
    i Tried that but it did not work – TARDIS_FREAK Jul 1 '16 at 1:59

Starting with 1.9, the parts of the game that you use JSON (/tellraw, /title, and signs) needs to be actually JSON compliant, so you need to use quotation marks on actions too. This should work:

/tellraw @p ["",{"text":"my text","color":"red","bold":true,"underlined":true,"clickEvent":{"action":"open_url","value":"url"}}]

You can generate JSON like this at https://www.minecraftjson.com

  • I believe tellraw is the only affected command – Unionhawk Jul 1 '16 at 1:55
  • sorry that did not work but thanks – TARDIS_FREAK Jul 1 '16 at 1:55
  • but i think it dos need a JSON compliant like you said – TARDIS_FREAK Jul 1 '16 at 1:57
  • @Unionhawk /title and sign text also requires strict JSON. Book pages have yet to conform but they eventually will. – Skylinerw Jul 1 '16 at 2:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.