4

I recently updated to Windows 10 from 8.1 and have started to have problems with Minecraft. For Minecraft 1.9 and up I get extreme lag. It lags in the main menu as well as when I'm in-game. I have updated all of my drivers, messed with some java settings in the launcher, and nothing seems to work.

Computer specs:

Processor Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz (Can go up to 2.3 GHz)

Video Card Intel(R) HD Graphics Family

RAM 6.0 GB

Operating System Microsoft Windows 10 (build 10586), 64-bit

  • 1
    More information would be helpful. First - how much RAM do you have installed? I used to have 8 gigs when i played MC and it was okay for the MOST part but it did drop a lot. As for the second, what CPU do you have? Same concept, poor components = poor performance. So, What do you have fitted to your PC, RAM and CPU wise? – Alex Spencer Jul 4 '16 at 15:44
  • 1
    Try Optifine – Jacques Marais Jul 5 '16 at 10:07
  • Have you tried to open the game in compatibility mode with Windows 8? – Luk3 Jul 5 '16 at 13:11
  • @CommandFox Tried Optifine, still the same issue. I lag at the main screen on 1.9-1.10. But on 1.8.9 and below, it's perfectly fine. I can play modpacks with 200 or so mods on 1.7.10 perfectly fine. – LucidiousXIV Jul 5 '16 at 15:03
3

You say this happens as soon as you updated to windows 10. I'm also running Windows 10 and had lots of crash messages. There are certain things you can do to stop this:

1. Look at your resources. Because you upgraded, your resources could be hogged by some program. To do this, press CTRL + ALT + DELETE (Or DEL) and then press on Task Manager. Make sure to have minecraft open. enter image description here In this case, eclipse is taking a lot of Memory (Or RAM), so you would want to close it. Also, Explorer is taking decent Networking power, so unless you need it, I would recommend closing it. The darker the orange, the more power the program needs. Try closing all power hungry applications and then continue.

2. See if you need to allocate more RAM to your profile. If you tried step one and still are experiencing lag, see your technological page. To do this, go to OPTIONS --> CHAT SETTINGS --> and make sure Reduced Debug Info is set to off. Next, go to a world and press F3. A bunch Of text will appear. enter image description here While the 1.9 menu might be a bit different, the four most important things are in the top right corner: your Java version, RAM, Allocated RAM, and your CPU specs. In this photo, we see that 80% of RAM is being used. The computer will still function fine until somewhere up 96% I believe. If you think this is the problem, go into the start menu and search configure Java , go to the Java panel, and hit view. Depending on your RAM, you may want to allocate different amounts of memory. To allocate memory, edit Runtime Parameters and add the following:

  1. -Xmx This specifies that you want to configure RAM
  2. A number of Gigabytes (G) or Megabytes (M) you want to add. Since you are running on 6 gigabytes, I would recommend three or two. If you are converting G to M, multiply G by 1024 to get your M (or Megabytes).

The final product would look like: -Xmx2G or something like this photo:enter image description here

Next, we need to go to Minecraft's settings. To do this, open your launcher (which of the time of this post should be 1.6.61) and go to edit profile. First, find the version you allocated more RAM to. If you only have one Java version installed, you should be set to go. If not, go to C:\Program Files (x86)\Java (C being your computer drive). Next, find the version. This should be marked under Product when you allocated RAM. Next, copy (CTRL + C) and paste the directory C:\Program Files (x86)\Java\JRE1.8.0_65\bin\java.exe (when JRE1.8.0_65 is the folder) and in Minecraft's profile editor under Java Settings (Advanced) [Bottom] and check Executable: and replace the current path with your path which you copied (CTRL + C) and paste it (CTRL + V). Under that, check JVM arguments, and copy and paste this: -Xmx128M -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M where 128M was the amount of RAM you allocated (Both in Xmx128M and Xmn128M). Once this is done, you can save the profile and try playing again. Hopefully, this time you will have more RAM and less lag.

3. Try running minecraft's older launcher. In my case, this solved the problem. Here Is the Link. This version will require you to have Java installed, however you will not need to rewrite your profile or anything like that besides login. Once you download this, try it. If this does not show any signs of lag, continue using it.

4. Try updating Java. The Java version may also be the problem. Try updating to the latest version at the time of this post (8u91) and then restart minecraft.
5. Run Minecraft in safe mode. While I doubt this would help, your comments say all of the above do not work so this may solve it. To turn on / boot into safe mode: (http://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10)

Hold down shift, then press Restart. After Windows 10 reboots, you can choose which boot options you want enabled. To get into Safe Mode, you have three different options. To enable Safe Mode press the F4 key on your keyboard, to enable Safe Mode with Networking press F5 and to enable Safe Mode with Command Prompt press F6.

This will disable any non-critical programs from starting. From here, run minecraft. If it works perfectly, restart and follow into Part II.

| PART II |

If minecraft works perfectly in safe mode, go into task manager CTRL + ALT + DEL and run task manager. From there, goto the Startup tab and disable any programs you don't feel should be there. If you don't know which ones to disable, try disabling all of the programs and enabling them one by one.

  • 1: Resources are fine 2: Ram is fine, around a constant 20% 3: Tried the old launcher, still the same issue 4: Updated Java, still the same. – LucidiousXIV Jul 5 '16 at 3:20
  • 1
    @LucidiousXIV I'll update it with some new things. – RookieTEC9 Jul 5 '16 at 15:52
  • Have you found anything out? – LucidiousXIV Jul 7 '16 at 0:48
  • @LucidiousXIV Sorry, I was writing when my laptop shut down. – RookieTEC9 Jul 8 '16 at 8:28
  • I tried that and the results are still the same :C – LucidiousXIV Jul 10 '16 at 3:00
2

I had the same issue on Windows 10. Noticed only 1024M is used while MC/Forge is loading.

Changed memory to 2048M and it started to work smoothly. (more info here)

In ATlauncher:

Configure Java memory in Minecraft ATlauncher

In Minecraft launcher:

Configure Java memory in Minecraft launcher

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.