When I play in a group, I am able to use my microphone with no problems. However, when I turn on the microphone in the team voice chat, I am constantly broadcasting static to the rest of the team. There isn't any background noise that I can hear. I can see my name in the top left with the speaker symbol even when I am not talking or I mute my microphone. Does anyone know why this might be or what I can do about it?


Are you sure you've set your microphone to 'Push-to-talk' in the game's settings while you're in team chat?

If yes, then the game might be using some other recording device. Check and disable others in your windows sound panel under Recording Devices.

| improve this answer | |
  • I have push-to-talk turned off intentionally. The part that is weird is that it doesn't have any problems when I am in a group voice channel, only on the team channel. – TheCaptan Jul 5 '16 at 16:22
  • I had a similar problem when I forgot to disable the mic on my webcam. Do you have a webcam or other device with an integrated mic that might be broadcasting instead? – JamesCW Jul 5 '16 at 17:29
  • I tried it with push to talk and didn't have any issues. But it doesn't answer why I am getting static with open mic. – TheCaptan Jul 6 '16 at 16:30
  • @JamesCW I unplugged everything just to make sure. I am using my laptop's built in microphone and it is still happening. – TheCaptan Jul 6 '16 at 16:31
  • Have you tried disabling each and every single one of your Recording Devices? – Codestrife Jul 6 '16 at 20:41

If you're on PC press the "P" key by default to open the voice channel selection menu, then next to the blue "Team" tab press the icon that looks like a headset, this will put you in the team voice channel and allow you to speak to your team.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.