2

On my server, I accidentally used a command block to make /kill @p repeat over and over.

I don't know the coordinate of the command block, and I don't have McEdit. I am using PuTTY to connect to the server.

Is there any way I can disable the command blocks, and if so, how?

1

SSH into your server, and open your server.properties file in your favorite console-based text editor.

From there, find the line that looks like this:

enable-command-block=true

Change it to look like this:

enable-command-block=false

Restart the server through whatever means you've used to set it up, and remove the command block. Optionally, re-enable command blocks by changing the value back to true and restarting the server.

  • To whoever downvoted this answer: Can you please leave a comment explaining why so that I can improve this answer and all of my future answers? Thanks! – Kaz Wolfe Jul 7 '16 at 23:36
0

Yes, there are several different ways to fix it.

  • Download MCedit for your computer. Open your world with MCEdit, edit it, and then save it. This is easier, and MCedit will come in handy for you in other ways I'm sure.
  • If you don't care about the place you're in, you can /tp far away from the block where it can't affect you, and reload chunks.
  • You could also go to 'server.properies' and disable command blocks.
  • If you're going to downvote my answer, please tell me why, and what I can do to improve it. – ALX Jul 7 '16 at 23:38
  • Always happy to help @Turtlezcraft – ALX Jul 7 '16 at 23:39
  • @ALX If I had to guess, it was the fact that the post was poorly formatted and looked low-quality when the downvote was actually issued. That appears to be fixed now, and your score is back to 0 (+1/-1 split). – Kaz Wolfe Jul 7 '16 at 23:42
  • It was badly formatted at first! I've never used the mobile stack exchange app before, and am still unfamiliar with it. @KazWolfe – ALX Jul 7 '16 at 23:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.