0

I had a world that me and my friend had made. My friend started playing with redstone and command blocks. There is an extremely fast clock that you can make with command blocks. (One command block set a block to air, the other command block setting that same space at redstone block). He then used that clock to power a third command block which spawned an ender dragon. The world is too laggy to do anything. I jiggle the mouse and it comes through about 2 1/2 minutes later. We were running version 1.10.2 (not snapshot)

I have tried opening the world in version 1.0, before there was redstone and ender dragons. That depended completely on whether the game deleted the "unknown" data. That did not work.

I would really like to have that world saved. I am at a loss as what to do. Thanks in advance.

  • Have you managed to get rid of the command blocks? – Ben Jul 15 '16 at 6:37
1

Note that if you opened your world in Minecraft version 1.0 WITHOUT backing up the 1.10.2 version, you might of caused serious (and irreversible) damage to the world file. Assuming you didn't, here is the command to kill all ender dragons:

/kill @e[type=EnderDragon]

Note that you have to a OP on the server to run this command. If on singleplayer, open the world to LAN and turn on the "enable cheats" option to OP yourself.

Comment below if you need more help.

  • This only solves part of the problem. While yes it will clear out the dragons, the clock will continue to spawn them - so that needs to be addressed as well. – Ben Jul 15 '16 at 6:38
1

If you're using the server, in server.properties change enable-command-block=true to false. Then do /kill @e[type=EnderDragon]

1

Use MCEdit to remove the command block. if you don't know how to use mcedit look on youtube. Download MCEdit here: http://www.mcedit-unified.net/

0

Get a Repeating Command Block then put in it /kill @e[type=EnderDragon] Then press Done. Then put a lever on top of the Command Block then flick it so when an Ender Dragon spawns it will get killed instantly! (Advice:In chat write this:/gamerule commandBlockOutput false)

  • i have already fixed the problem. thanks for you answer though. – Tyler Richardson Jul 17 '16 at 18:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.