1

I use Steam in English, but I first installed it in Spanish. Yesterday, it randomly changed back to Spanish and wouldn't change to any other language, even after restarting. Today, I decided to replace the app with a brand new one from the English installer. The new app gets me a prompt saying: “The app ‘Steam’ can't be opened.”. What did I do wrong?

8
  • Did the installer download properly? Have you tried redownloading it? Jul 16, 2016 at 8:51
  • Yes, I did download it twice. The result was the exact same.
    – inakilbss
    Jul 16, 2016 at 8:58
  • AFAIK language files will be downloaded after changing the client language. Maybe the download/check of those files failed.
    – dly
    Jul 16, 2016 at 9:27
  • I tried about a dozen times, even once in another language just to see if it was just English. But it wasn't just that. Steam refused to change even after restart.
    – inakilbss
    Jul 16, 2016 at 9:29
  • What error code are you getting? There should be a number after the error you're getting.
    – eijen
    Jul 16, 2016 at 14:28

2 Answers 2

1

I found a guide in the Steam forums: http://steamcommunity.com/discussions/forum/2/458604254461190576/

It seems that a restart should cut it. If not, renaming the app. If not, removing only the app, inputing steam://flushconfig in Safari, restarting and reinstalling the app will cut it for sure.

0
-1

What I'm suggesting to do is extreme but may solve the problem. However, you'll want to back up your data first in case it doesn't work.

Since there's no error code for the error you're getting I'm suggesting the simplest thing possible that might fix it: actually deleting Steam's data storage. What you can't see right now is that Steam actually stores stuff inside a folder called Library in your home folder. I'm not sure what this is called in Spanish in this case, so I'll be assuming you can do the translation yourself.

To get there, press Command-Shift-G on an open Finder window and type in ~/Library. Once there, navigate to Application Support and you'll see a folder named Steam.

Delete the entire folder and re-install Steam. This will mean you have to re-install your games if re-installing Steam works, but your saves should be safe since they tend to be stored elsewhere.

5
  • or just remove everything in Steam folder except steamapps folder to keep your games.
    – ave
    Jul 17, 2016 at 12:45
  • I know about Application Support, and deleting the entire Steam folder doesn't do anything. It's definetely an OS error.
    – inakilbss
    Jul 17, 2016 at 16:35
  • @inakilbss Have you tried restarting? Sometimes doing something simple like that will fix the problem.
    – eijen
    Jul 18, 2016 at 16:55
  • Have you read my answer?
    – inakilbss
    Jul 18, 2016 at 19:09
  • My bad, I missed it. This just seems like a mystery to me, honestly. The only other thing I can think of is check Activity Monitor to see if anything weird is going on there.
    – eijen
    Jul 19, 2016 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .