0

Ever since I tried to upgrade to 1.10, my Minecraft worlds won't come up. Sometimes I can get in the world but it says at the top "Minecraft _.__._ Not Responding". After it says that it gets off the game. SOMEONE HELP ME!! This is what it says after it gets out of game,

Completely ignored arguments: [--nativeLauncherVersion, 307]
[17:23:49] [Client thread/INFO]: Setting user: Sup3rGam3rSky
[17:23:49] [Client thread/INFO]: (Session ID is <censored>)
[17:24:00] [Client thread/INFO]: LWJGL Version: 2.9.4
[17:24:01] [Client thread/INFO]: Reloading ResourceManager: Default
[17:24:04] [Sound Library Loader/INFO]: Starting up SoundSystem...
[17:24:04] [Thread-6/INFO]: Initializing LWJGL OpenAL
[17:24:04] [Thread-6/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[17:24:04] [Thread-6/INFO]: OpenAL initialized.
[17:24:04] [Sound Library Loader/INFO]: Sound engine started
[17:24:23] [Client thread/INFO]: Created: 512x512 textures-atlas
[17:25:08] [Server thread/INFO]: Starting integrated minecraft server version 1.8.6
[17:25:08] [Server thread/INFO]: Generating keypair
[17:25:09] [Server thread/INFO]: Preparing start region for level 0
[17:25:10] [Server thread/INFO]: Preparing spawn area: 19%
[17:25:11] [Server thread/INFO]: Preparing spawn area: 52%
[17:25:12] [Server thread/INFO]: Preparing spawn area: 96%
[17:25:13] [Server thread/INFO]: Changing view distance to 17, from 10
[17:25:15] [Server thread/INFO]: Sup3rGam3rSky[local:E:0aa54fc8] logged in with entity id 244 at (-511.0912092554738, 72.0, 346.7127868621491)
[17:25:16] [Server thread/INFO]: Sup3rGam3rSky joined the game

#
# There is insufficient memory for the Java Runtime Environment to continue.
# Native memory allocation (malloc) failed to allocate 32744 bytes for ChunkPool::allocate
# An error report file with more information is saved as:
# C:\Users\gamer_000\AppData\Roaming\.minecraft\hs_err_pid2832.log
#
# Compiler replay data is saved as:
# C:\Users\gamer_000\AppData\Roaming\.minecraft\replay_pid2832.log
AL lib: (EE) alc_cleanup: 1 device not closed
Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

Someone please help!!

  • If you're allocating memory, don't, or allocate less, and if you aren't then do so. It seems to be a java runtime issue with memory allocation – ALX Jul 19 '16 at 22:44
  • The contents of C:\Users\gamer_000\AppData\Roaming\.minecraft\hs_err_pid2832.log would help. Try to use the default ressource pack or allocate more memory. A 512x512 pack needs a lot more than 32kb. How much RAM does your PC have? – dly Jul 20 '16 at 7:00
1

It seems like your Java instance that's starting minecraft has hit its max memory.

How do you launch minecraft? If you're using a minecraft launcher, you can pass arguments to increase the allocation.

Here's a stackoverflow post that might help.

A few ways sugested on this post include:

1) Grab a 64 bit JRE

2) Allocate additional memory using the option parameter set -d64 -Xms512m -Xmx4g.

  • Problem here is that unless this guy is a computer wizard/programmer, he is not going to know how to launch minecraft with command line parameters... If he has already got a 64 bit installation, then this SO question isn't helping much. – Ashwin Gupta Jul 20 '16 at 5:59
  • 2
    Setting up more memory without knowing how much RAM is installed is a bad idea. – dly Jul 20 '16 at 7:02
  • @AshwinGupta You can change launch parameters in the minecraft launcher – Derkades Jul 21 '16 at 9:47
  • @Robin interesting I didn't know that. I figured you had to run the jar manually. – Ashwin Gupta Jul 21 '16 at 14:48
  • @dly he can easily check. System info tells you. – Ashwin Gupta Jul 21 '16 at 14:49
0

While @anonymous coward did technically answer the question, I will explain how to fix it, step by step.

Help for a copy of Windows
1. Update Java. You can click the link here: Java Update 8u101
2. Figure out how much ram you have. To do this, press the windows key. Next, search About Your PC in windows 10 (to locate it manually, go to the app titled SETTINGS then click About). Scroll down until you see Installed RAM and System type. If your system type is x86 or 32 then you will need to download the Windows x86 version. Once you install this, go to the search bar type configure Java, and run the program. For all the other versions then 8u101 (1.8.1_00) I believe or (1.8.0_100) click on them and click remove. Make sure 8u101 is enabled in both User and System and all other versions are removed. IF YOU ARE RUNNING WINDOWS 7, go to control panel , search about (top right ) and click on the green system. You will find the same two properties here (INSTALLED RAM & SYSTEM TYPE).
3. Allocate more RAM Next, we will do a conversion. Find the amount of your INSTALLED RAM, divide it by 4, and then multiply it by 1024. So if you had, say 8GB installed, you would get 2048.
Once you get this number, go to your minecraft launcher. Next, click edit profile and scroll down to JVM ARGUMENTS under JAVA SETTINGS (ADVANCED) and copy this into the section (Deleting all other arguments) -Xmx256M -Xms256M where 256 is the number you calculated.

I don't recommend 256M. Do 2048. or 1024.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.