0

I am completely new to Dwarf Fortress and just got version 0.42 running on OS X 10.11 (I updated SDL and all of that). However, I started up the game, created a new world with all the default parameters, waited for it to generate, and once it was done with 250 years of history I pressed enter assuming it would put me in the game. All this did was bring me back to the title screen and there isn't even an option to load a game. I checked in the save folder and all there is is another folder that says current. I am missing something or is this simply a fatal bug? [EDIT] There also isn't a "Start Playing" button. I'll attach a screenshot after I have went through the whole generation process. Screenshot

  • You already found a solution that works for you, but I will leave this here for others. The world generation is usually not even near finished at 250 years, and the instructions at the bottom of the screen at this time say "Enter or ESC to pause/finish." after pausing, the final abort key is 'a' which I always expect to be for accept. The actual, use this world as is stands key is 'u'. I would guess that you accidentally aborted the world instead of accepting it. – Nick Jul 23 '16 at 19:58
0

Generating a world isn't the same as starting an actual save file. Once you've made a world, you have to start your game as well, being brought back to the title screen is normal. If you choose to start a new game, you should see your newly generated world on which you'll be able to embark.

|improve this answer|||||
  • But there is no start playing button. – Dylan Siegler Jul 23 '16 at 16:54
  • Oh somehow I got version 0.34.11 so that must have been my problem. Works with 0.43.05. Thanks! – Dylan Siegler Jul 23 '16 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.